summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-07 16:16:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-07 16:23:46 +0100
commit994604c3262e4058a1e06b3b8cde8f22067420a4 (patch)
treeaeeae7f459348753d9660ae38f9a0784352e337e /dev-python/future/future-0.17.1.ebuild
parentdev-libs/nss: Version bump 3.51 (diff)
downloadgentoo-994604c3262e4058a1e06b3b8cde8f22067420a4.tar.gz
gentoo-994604c3262e4058a1e06b3b8cde8f22067420a4.tar.bz2
gentoo-994604c3262e4058a1e06b3b8cde8f22067420a4.zip
dev-python/future: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/future/future-0.17.1.ebuild')
-rw-r--r--dev-python/future/future-0.17.1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/future/future-0.17.1.ebuild b/dev-python/future/future-0.17.1.ebuild
deleted file mode 100644
index 889324f6510c..000000000000
--- a/dev-python/future/future-0.17.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
-HOMEPAGE="http://python-future.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-bootstrap-theme
-distutils_enable_tests pytest
-
-# TODO: make numpy unconditional when it supports py3.8
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
- python{2_7,3_{5,6,7}})
- )
-"
-
-python_prepare_all() {
- # tests requiring network access
- rm tests/test_future/test_requests.py || die
- sed -i -e 's:test.*request_http:_&:' \
- tests/test_future/test_standard_library.py || die
-
- distutils-r1_python_prepare_all
-}