summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-30 18:07:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-30 18:08:56 +0200
commit02196c63a552d4cce53f85053fb0ed49836c9a50 (patch)
tree5a77ec2958d442877df273a6a3f8240e184dbe28 /dev-python/genson
parentdev-python/genson: Fix test failures (diff)
downloadgentoo-02196c63a552d4cce53f85053fb0ed49836c9a50.tar.gz
gentoo-02196c63a552d4cce53f85053fb0ed49836c9a50.tar.bz2
gentoo-02196c63a552d4cce53f85053fb0ed49836c9a50.zip
dev-python/genson: PEP517, py3.11
Closes: https://bugs.gentoo.org/896782 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/genson')
-rw-r--r--dev-python/genson/genson-1.1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/genson/genson-1.1.0-r1.ebuild b/dev-python/genson/genson-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..efd955f3b71a
--- /dev/null
+++ b/dev-python/genson/genson-1.1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="GenSON is a powerful, user-friendly JSON Schema generator built in Python"
+HOMEPAGE="
+ https://github.com/wolverdude/GenSON/
+ https://pypi.org/project/genson/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # https://github.com/wolverdude/GenSON/pull/70
+ sed -i -e 's@TEST_URI@test://@' test/test_builder.py || die
+}