summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-21 07:15:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-21 07:59:58 +0200
commit5e9403e9364c5e91f61f5a557c39e11d2f9c6c43 (patch)
tree68267e517c2bc7c2fcc1236a64e7e977c2e4182a /dev-python/geventhttpclient
parentdev-python/jupyter_packaging: Bump to 0.12.2 (diff)
downloadgentoo-5e9403e9364c5e91f61f5a557c39e11d2f9c6c43.tar.gz
gentoo-5e9403e9364c5e91f61f5a557c39e11d2f9c6c43.tar.bz2
gentoo-5e9403e9364c5e91f61f5a557c39e11d2f9c6c43.zip
dev-python/geventhttpclient: Bump to 1.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild52
-rw-r--r--dev-python/geventhttpclient/metadata.xml4
3 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 191fcf5dc10d..471a605c3854 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1 +1,2 @@
DIST geventhttpclient-1.5.3.tar.gz 58447 BLAKE2B a1cf529c6d40ee81ebe17cb066f2d837cf3d5ce2511bb735c1a63503b612c98c17c91f08de99d604c9ff6ebfa7e6502c338e7fbbc86de954ae7e559966aa8006 SHA512 9a0ed907f73f7f5ff8675502ef6fc82bff7b543d0a2d22e1eca5aba3592675a87fe09c48981f496b7f63a660e7eab5f68801ae74da8c33ac9d9bf55a0425eed1
+DIST geventhttpclient-1.5.4.tar.gz 59551 BLAKE2B d1bda5315a92afeb408f33043c8ccf5911d6519dbe50266688f0b123fd92a95f1cb9cea449676117ea051af1400c656fe47d241b6e4e03803dc017806b5e0be4 SHA512 10d9ace4a555a5c39d8b737d96484041f9e704df41b8a3cca3b05b3c9ccb30d0490d154fa47a45edcad762a2e0807ca89425ed484275ee1b3098f0094fd6d166
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild
new file mode 100644
index 000000000000..d4807ee44f57
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="
+ https://github.com/geventhttpclient/geventhttpclient/
+ https://pypi.org/project/geventhttpclient/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[events(+),${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Skip tests which require internet access
+ epytest -m "not online"
+}
diff --git a/dev-python/geventhttpclient/metadata.xml b/dev-python/geventhttpclient/metadata.xml
index e16d44999f05..f7551c444a51 100644
--- a/dev-python/geventhttpclient/metadata.xml
+++ b/dev-python/geventhttpclient/metadata.xml
@@ -11,7 +11,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">geventhttpclient</remote-id>
- <remote-id type="github">gwik/geventhttpclient</remote-id>
- <bugs-to>https://github.com/gwik/geventhttpclient/issues</bugs-to>
+ <remote-id type="github">geventhttpclient/geventhttpclient</remote-id>
+ <bugs-to>https://github.com/geventhttpclient/geventhttpclient/issues</bugs-to>
</upstream>
</pkgmetadata>