summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-26 05:01:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-26 05:01:11 +0200
commit78a7183ce3e8f4c0ef065712f5efab7922d607e7 (patch)
treefb7f6a3edb4b4632c10a8338c751b8c230c69d95 /dev-python/google-auth-oauthlib
parentdev-python/pytest-metadata: Bump to 2.0.3 (diff)
downloadgentoo-78a7183ce3e8f4c0ef065712f5efab7922d607e7.tar.gz
gentoo-78a7183ce3e8f4c0ef065712f5efab7922d607e7.tar.bz2
gentoo-78a7183ce3e8f4c0ef065712f5efab7922d607e7.zip
dev-python/google-auth-oauthlib: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 1810ea684410..f591a0434586 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-library-python-oauthlib-0.5.2.gh.tar.gz 53842 BLAKE2B 7adcd9f339ec9a5528308fcc0fee1cbbe96440e1bfe5c7cc9c94808668e22801b612d291a2419333888194c3224838ac40f9d0656381825bd660067470f58910 SHA512 eaf296a0e0504e8249637a8db7531c10b120f28abeeab3e1fe8f366b4279c396509188e83f8a0ec56be85063430ceb691d6d926cee33d4f166bbcc4425e538db
DIST google-auth-library-python-oauthlib-0.5.3.gh.tar.gz 69613 BLAKE2B 74338894f35fd1cd8802ea56952561ce0e801fecb2f994b71caf3c6b62a22e8b85f8a5b40f5571b05225a565b373865377d321625aeea2dafcc0cafb89da1492 SHA512 76c855e9becd57d3cb3bb0b203ad77ef17dc04e8be8b96d17a9c1f29474a8b180edb725e835d0552c5eddbb387cc463e88b076dd6d11635e6d45798224f09188
DIST google-auth-library-python-oauthlib-0.6.0.gh.tar.gz 70025 BLAKE2B 2d87390a629d967b0f2aef5f56712d3defc2b460a67f2bf633bb628875161f9ddbb4f229426ce2b42dcf805feefe8101ed3bacd72ced630c0be4fe40bd926c7e SHA512 1aa42498a5875812db922b30eb20cdf124935f95f5cabd224acfb82c9ed61714cfc3c6af2168e75cf11aaa8550e41c48f30fc1d467d1b7be511bf5cb522104e8
+DIST google-auth-library-python-oauthlib-0.7.0.gh.tar.gz 70179 BLAKE2B d0e70d796c11a0f3a9be8dba58dc030ef1dfd6dc3dd13e3dc74530c5d1edba3863b7a9bb4c1f90879b70a585f1d193344dea96aa45fbb08a7e28a25a31a22b6f SHA512 fe33b0a4528f6f6602b73de50c017779e7aba5d8891ef43cb3350d337e3e62a78a4126479fae0a8732dd7c4bd35210182f4a1b7f61da06af043dfff7d91ffe24
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.0.ebuild
new file mode 100644
index 000000000000..9f0dd721dba7
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest