summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-18 05:57:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-18 05:58:39 +0100
commitf81b0c917ec08b10944bab411ea53758c6155022 (patch)
tree16f006b5cf58723901712783f360827249792096 /dev-python/graphviz
parentdev-python/python-stdnum: Bump to 1.20 (diff)
downloadgentoo-f81b0c917ec08b10944bab411ea53758c6155022.tar.gz
gentoo-f81b0c917ec08b10944bab411ea53758c6155022.tar.bz2
gentoo-f81b0c917ec08b10944bab411ea53758c6155022.zip
dev-python/graphviz: Bump to 0.20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest1
-rw-r--r--dev-python/graphviz/graphviz-0.20.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index c9275247c609..ae10c479b2f5 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1 +1,2 @@
DIST graphviz-0.20.1.gh.tar.gz 188952 BLAKE2B 65d0b993e01492894b6d245c0869412b4956e5d55f9d8d490505c8f3477dc5ab98739cf0bf1aa1a15c4bacb2db4c2807659ce410ca65503c5876ffdc278e959f SHA512 34d340469856777f03b9c9e6d28f232908797bc1456a5b50104dd2f7dc8b7488afc7b29a564d57707ae96f3291f5ae90b8140ab64e378b82f271b5521763fb55
+DIST graphviz-0.20.2.gh.tar.gz 190548 BLAKE2B 786f43fa29e6a09c837c9d13f1a41ca385e4993c52dd1467964c1c8506175e9f1bae864a7ca2ad301d1cbdb1d639a1314f2a2af30e01c4a6ecd17f93b1416871 SHA512 bd07c0ed46f380df2ace4d8396f1406455ff1b117fdb431337ebcf54a112b1894275e2d3e84c9711a25118c880f64dcb82c952aa1d8b704c1cd4c6215e651a1a
diff --git a/dev-python/graphviz/graphviz-0.20.2.ebuild b/dev-python/graphviz/graphviz-0.20.2.ebuild
new file mode 100644
index 000000000000..920ddb5ef469
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.20.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="
+ https://graphviz.readthedocs.io/
+ https://github.com/xflr6/graphviz/
+ https://pypi.org/project/graphviz/
+"
+SRC_URI="
+ https://github.com/xflr6/graphviz/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:license_file:license_files:' \
+ -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_IGNORE=(
+ # workaround https://github.com/pytest-dev/pytest/issues/12123
+ tests/backend/conftest.py
+ tests/conftest.py
+ )
+ epytest -p pytest_mock
+}