summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-24 04:11:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-24 04:41:04 +0200
commit6a1d53acf3897ea1b11e91438cb1dba76c062305 (patch)
tree504e5a3e07c8dab693b047e3a8338847a1d1b859 /dev-python/hishel
parentdev-python/importlib-metadata: Bump to 7.2.1 (diff)
downloadgentoo-6a1d53acf3897ea1b11e91438cb1dba76c062305.tar.gz
gentoo-6a1d53acf3897ea1b11e91438cb1dba76c062305.tar.bz2
gentoo-6a1d53acf3897ea1b11e91438cb1dba76c062305.zip
dev-python/hishel: Bump to 0.0.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hishel')
-rw-r--r--dev-python/hishel/Manifest1
-rw-r--r--dev-python/hishel/hishel-0.0.29.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/hishel/Manifest b/dev-python/hishel/Manifest
index 4120bfc5ffbc..bb41fbeadb34 100644
--- a/dev-python/hishel/Manifest
+++ b/dev-python/hishel/Manifest
@@ -1 +1,2 @@
DIST hishel-0.0.27.gh.tar.gz 828343 BLAKE2B 57c42988bb64ef0a36bfe15527fae4a06cf1945609458266c29c0ba9423002c8c7c3beb0b1276dd4aa7d8b3a4f4575f5c8d570d7d66b97ea757988f3e673b651 SHA512 c348bc7ef236a9379f4c45f3cfa3eb74ea1c11be3b3dc533e7864c788d029137720de7612210873971d8ccd6768379ee26a4782c6c7fdf87ce4e4028489b6012
+DIST hishel-0.0.29.gh.tar.gz 828680 BLAKE2B 2869f53e04e92d5c6ccaeb3234a299a075db8429b3b8f77ac9671764b65a4a7d360451e934651789caf2e654b3e5b18819b741b52abe89867157599b921d5a40 SHA512 a16b2c198ea93c2445e0f572e5432c1f44b12ed0e301e52ed46c2c849a5a324457f88ca50c5e98283ceb9aaddf1e1ea4a11644cf61dd0ca4a25f956950c6da23
diff --git a/dev-python/hishel/hishel-0.0.29.ebuild b/dev-python/hishel/hishel-0.0.29.ebuild
new file mode 100644
index 000000000000..07503f286cee
--- /dev/null
+++ b/dev-python/hishel/hishel-0.0.29.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="An elegant HTTP Cache implementation for HTTPX and HTTP Core"
+HOMEPAGE="
+ https://github.com/karpetrosyan/hishel
+ https://pypi.org/project/hishel/
+"
+SRC_URI="https://github.com/karpetrosyan/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-db/redis
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's:mock_s3:mock_aws:g' \
+ -e '/import anysqlite/ d' \
+ -i tests/_async/test_storages.py \
+ tests/_sync/test_storages.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # tests that need anysqlite
+ tests/_async/test_storages.py::test_sqlitestorage
+ tests/_async/test_storages.py::test_sqlite_expired
+ tests/_async/test_storages.py::test_sqlite_ttl_after_hits
+ )
+
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Starting Redis"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}