summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-02-29 00:46:31 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-02-29 00:47:01 +0100
commit703b2712e3c30dc2793d366aa5e76a734c19a625 (patch)
tree2333e4f23643c7c91a3ed697008c195015e1b9ee /dev-python/humanize
parentapp-portage/g-octave: python3 support and more from git (bug #706214) (diff)
downloadgentoo-703b2712e3c30dc2793d366aa5e76a734c19a625.tar.gz
gentoo-703b2712e3c30dc2793d366aa5e76a734c19a625.tar.bz2
gentoo-703b2712e3c30dc2793d366aa5e76a734c19a625.zip
dev-python/humanize: bump to 1.0.0, drops removed doc, add Py3.8
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-1.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 6be0f954afe5..10c841b0d844 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-0.5.1.tar.gz 20507 BLAKE2B 55d7b598b32658b1d4c4741b37b5c33bdc9d63a5a779455e2fb93e1e4c3a0d8fd58e8522ef82734e1ba2b161fd881829373ba3569baffd9ea3271ad7ed3e7568 SHA512 dd7ad7f3c564cc6abcb6b128e50dbea7f19f7f418bfd936aae2472961c53ec71202133c5c2b5b930ef41ef807b51d6ba1210565627ed32c0b41acc0abd32a2d5
+DIST humanize-1.0.0.tar.gz 34411 BLAKE2B dc1d2f3c5db2ddbecccf7c1f9894a7fa7ddbb98a530e971ecc1de2b666a1b3a21e2770f25cefa37029d1d439d03e68bbb5a3496cc2fbd074b8bb427a09f52cf1 SHA512 2e012b7be88d0297301f25ecba7ba8083f5fc6384715a657c815373c6f2742f1429e62363e6e16f1bfc85c41b8ab8d4a361112045414e9aef038c12783df2592
diff --git a/dev-python/humanize/humanize-1.0.0.ebuild b/dev-python/humanize/humanize-1.0.0.ebuild
new file mode 100644
index 000000000000..be43d73ef82d
--- /dev/null
+++ b/dev-python/humanize/humanize-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# The package uses pkg_resources to determine its version
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ # The package uses pkg_resources to determine its version
+ distutils_install_for_testing
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}