summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-17 07:22:24 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-17 07:24:51 -0400
commit6baf797fe4d0f951515d19997f13f2a08c660724 (patch)
tree64d0ea8f4baa96fca86c27c5f3bf4beb8ade41be /dev-python/hypothesis
parentdev-python/pycairo: version bump to 1.17.0 (diff)
downloadgentoo-6baf797fe4d0f951515d19997f13f2a08c660724.tar.gz
gentoo-6baf797fe4d0f951515d19997f13f2a08c660724.tar.bz2
gentoo-6baf797fe4d0f951515d19997f13f2a08c660724.zip
dev-python/hypothesis: version bump to 3.59.1
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.59.1.ebuild37
-rw-r--r--dev-python/hypothesis/metadata.xml2
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 4d520bdf6899..47c8691447c0 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-3.44.7.tar.gz 403113 BLAKE2B a929322db86a9f769dff43c668609ad1840
DIST hypothesis-3.45.3.tar.gz 430444 BLAKE2B d96ef466768c590138b829f32f8b2aef803f68e9d44cc0b40052611a6264727b8d298029c9322b2ccfc911f211e20770459da844e443daa7be12d981965884fa SHA512 2cd970695f23fc0e523f27e56bd0ac9e8f2f5ca2e4cc1042202e9dafc5045505a3c6d8490114b4adc359b2ab72a346130901daa6c74a8ac2c3230834cbb4c89b
DIST hypothesis-3.50.1.tar.gz 439102 BLAKE2B fb0731fdd7a22ce4a851879b09cbd4ea9bbcb0dc869c2e77745d776640b0f9d697b7c0ada05050ccb1cc758857fba8179b96472c704548ffd51acbe6c7250819 SHA512 2928a6a724ba616644e5ff4010ba19473789f6f953b0d00910cb6ecbafbb85750f4fe747d3cc808a3fc23b2b0cbe05507e9b28bf184e7e77ffef59dba2dfd54b
DIST hypothesis-3.6.0.tar.gz 73586 BLAKE2B b0ec133e8c71f752114211061155c15a7d536e771ba85eab6489440b2063d3083018bf8502d9e9dbc73105ee5f03060e3189e64574a3dfa052b091040e7e7915 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389
+DIST hypothesis-python-3.59.1.tar.gz 500529 BLAKE2B 5c171045e363f2337d7ca30797b9fc7f96430c805dd4b3ec78fe927247d2c2ba4a216789a82f1e956b89d66c5ecdb2050a5f93467f2d557a05d1d48507fc06db SHA512 c3aad4cc54152963806e09af5f351e60e30cd64ad48ba3d922451b10dbb1747ea3e5d432ebc611dcb0646687d7e8755051b967304e74798d091be0b2901c832f
diff --git a/dev-python/hypothesis/hypothesis-3.59.1.ebuild b/dev-python/hypothesis/hypothesis-3.59.1.ebuild
new file mode 100644
index 000000000000..fac7d09e539c
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.59.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/hypothesis/metadata.xml b/dev-python/hypothesis/metadata.xml
index 0eb6c1c42697..3b9d8f1161a1 100644
--- a/dev-python/hypothesis/metadata.xml
+++ b/dev-python/hypothesis/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">hypothesis</remote-id>
- <remote-id type="github">HypothesisWorks/hypothesis-python</remote-id>
+ <remote-id type="github">HypothesisWorks/hypothesis</remote-id>
</upstream>
</pkgmetadata>