summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 05:39:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 05:59:27 +0200
commita837fe50f74bb5c9a4a72bb5c0a2840fe48b8db6 (patch)
tree10b5ec5ad4b19c8bb668f5cd2ac1b283dbb0d2fa /dev-python/icalendar
parentdev-python/pyghmi: Bump to 1.5.61 (diff)
downloadgentoo-a837fe50f74bb5c9a4a72bb5c0a2840fe48b8db6.tar.gz
gentoo-a837fe50f74bb5c9a4a72bb5c0a2840fe48b8db6.tar.bz2
gentoo-a837fe50f74bb5c9a4a72bb5c0a2840fe48b8db6.zip
dev-python/icalendar: Bump to 5.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index a1370837e7f3..560b8122031d 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-5.0.4.tar.gz 102093 BLAKE2B 5bb618f8abfa8c96cdf45b0fd85f97ecfbe99361fb2eda08fe6ba43da1d01642e116218bc01353a745f6dc401278887d5ffc616fcf666691360174459c896362 SHA512 5b9b1b770c903bec4d8e5a4dc20b82d8e35eb86e6421d62abad640e65db20ccc71757a939e9ccb051653962ab5725e80dbc024703de158fee2cb0d608b8b5732
+DIST icalendar-5.0.5.tar.gz 103204 BLAKE2B 20887b535f595ab222f3aca8ac396a71b53975816663693f89277a03be41885780d0b15269cd5955e00eeda0867db46781ea2300f542bca1a18687d50e025989 SHA512 1c1e6c94e2caa07686bc12389c3a5b823478f1652695bc167af95c26f92bbd3d60fb4e540d74eb90db289c647bfd6e1c82e83ee8f89bc87b80100d8b6fe5dd90
diff --git a/dev-python/icalendar/icalendar-5.0.5.ebuild b/dev-python/icalendar/icalendar-5.0.5.ebuild
new file mode 100644
index 000000000000..163646f7a292
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}