summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-16 20:01:02 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-16 21:07:40 +0200
commit32e17ea966adb977ed33f0ec872d8bc2b3949f6e (patch)
tree60038fc2bd6d754cbaed87578b4e30928e3f0034 /dev-python/identify
parentnet-misc/openssh: Added verify-sig integration. (diff)
downloadgentoo-32e17ea966adb977ed33f0ec872d8bc2b3949f6e.tar.gz
gentoo-32e17ea966adb977ed33f0ec872d8bc2b3949f6e.tar.bz2
gentoo-32e17ea966adb977ed33f0ec872d8bc2b3949f6e.zip
dev-python/identify: add 2.4.12
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.4.12.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index cee0b6b7f4f2..edc8e64dfc27 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.4.11.gh.tar.gz 101383 BLAKE2B ed1c205ff54d437133eb3193cd200848687a928cb0f958124df039d44d59ce02477b9615142848340851c2664288bafb42aabfd96aab5de4bc80cf47ad1a0885 SHA512 3525325088d9e8e7e955fc7d044d65a23032dc38d287222173d99d66cad3d3c200e6948ee8250732bccf1bc6d5d2d8f92b6ebdac0a4a090ef154d535c7ff8f2d
+DIST identify-2.4.12.gh.tar.gz 101366 BLAKE2B 55c1b7642d3f273beb415fabc683bfff46c1039fcf146d7c9c09f53b2beffab82e5e687849cbae6b7d2d9d0502a340e635ced730afa6610d20d75f0412943635 SHA512 8b9554a0a726e6fd25ca0fe1031b0a8a114fe98e13e41e73ad6549495a0dc02a2047c151f7717d8df705aba661e11ab1c0e48eff0bcf4d2a0dcff00f5ace1eec
diff --git a/dev-python/identify/identify-2.4.12.ebuild b/dev-python/identify/identify-2.4.12.ebuild
new file mode 100644
index 000000000000..ca074bc25eff
--- /dev/null
+++ b/dev-python/identify/identify-2.4.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-python/ukkonen[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest