summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-09-02 17:08:35 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-09-02 17:09:07 -0700
commit4b55db493e92fe3a256cfc5049707d91d1b7b4e8 (patch)
treedcf26e8ed4d1202fec0a5797882fb677ed1b3883 /dev-python/ijson
parentdev-python/python-bugzilla: keyword ~ppc, ~ppc64 (diff)
downloadgentoo-4b55db493e92fe3a256cfc5049707d91d1b7b4e8.tar.gz
gentoo-4b55db493e92fe3a256cfc5049707d91d1b7b4e8.tar.bz2
gentoo-4b55db493e92fe3a256cfc5049707d91d1b7b4e8.zip
dev-python/ijson-3.1.1: Version bump, add pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 9aa023fca837..3caeed890ec6 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
+DIST ijson-3.1.1.tar.gz 124875 BLAKE2B 6f20efa076cf9e9a9f22eec65c7658440cc2ddffc2bf88054025f76f2df48e395d1c11a52501a45e7b5301448ce5874fb3e62d9111963f49f976ee68836c39d1 SHA512 c693444ac757c3b6e1f762d4a877a82b11ccaaecc922d34b868d236a78d9cf8f8648cb6d1188f0444caf61a0758f3080d3bfbd79c1ee51114bbd7c0a34bc633e
DIST ijson-3.1_p0.tar.gz 123536 BLAKE2B d8ed0da77e219aee8ca287a2ede4eccd8e965a5778ff95485376bcfdcca07b48ae5c0e22b271fad0a489342403b11716971663158f340c97b80031bb2cc8c060 SHA512 af2db5b3c9f2cc93aa2d15462b6476a970e5c394a8f5bd9740ebbe134e8a2fa973c95057447bd02d3c4262ddf22fc7d231840d3a91b919a1411bae07d38cfd93
diff --git a/dev-python/ijson/ijson-3.1.1.ebuild b/dev-python/ijson/ijson-3.1.1.ebuild
new file mode 100644
index 000000000000..8ea1c3bc00e1
--- /dev/null
+++ b/dev-python/ijson/ijson-3.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PV="${PV//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson
+ https://pypi.org/project/ijson/
+"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest