summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-08 04:45:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-08 04:52:33 +0200
commit5486045f09e60d24b0b5bedd1667075f17f9c471 (patch)
tree9abcf4d2cc8e33ac1a2aa0f7554aa055c200df62 /dev-python/inflect
parentdev-python/pydantic-core: Bump to 2.23.3 (diff)
downloadgentoo-5486045f09e60d24b0b5bedd1667075f17f9c471.tar.gz
gentoo-5486045f09e60d24b0b5bedd1667075f17f9c471.tar.bz2
gentoo-5486045f09e60d24b0b5bedd1667075f17f9c471.zip
dev-python/inflect: Bump to 7.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-7.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index 3e069c9b0baa..82a8bd5d24de 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1 +1,2 @@
DIST inflect-7.3.1.tar.gz 71980 BLAKE2B efb1224ec0514403db5db7cc572335a7f3dab09e7fe57559df736fee4598782c12fc9ae1d3ade89b41acc492996c7a93f04eff86c712b1c3f98f9404694f643c SHA512 562107d500ee488a35d809e4b7888af31fb90d7b07b9f6c328f66d8723a171227e639e0cbf43cb9610227faff6690a8af7205bc509f6764c9e22e9160f7ba5e1
+DIST inflect-7.4.0.tar.gz 72730 BLAKE2B eaaaa46a1f710f5b05165f3f894eb5a2437908299146369a2537a675a1d50facba56c7a9efa2e459b7cfb95a4f2c5f615d64948fb278a4a990423b40414f701a SHA512 fe3658a2f4c9303db90604268a525112c6a67f66ed37f6fbe76cd04a008658362e682413297dc1fcae6e6a0415098f3adaf0f205b781e1e24a050f59c9dc9021
diff --git a/dev-python/inflect/inflect-7.4.0.ebuild b/dev-python/inflect/inflect-7.4.0.ebuild
new file mode 100644
index 000000000000..d1cdcca00005
--- /dev/null
+++ b/dev-python/inflect/inflect-7.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/typeguard-4.0.1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest