summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 16:16:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 16:44:38 +0200
commitc11fbeacd4e2f36848249fee8efc104c9f8054b7 (patch)
tree887780d6398117989282c7dc2790b1faa44856f1 /dev-python/iniparse
parentdev-python/gst-python: Enable py3.13 (diff)
downloadgentoo-c11fbeacd4e2f36848249fee8efc104c9f8054b7.tar.gz
gentoo-c11fbeacd4e2f36848249fee8efc104c9f8054b7.tar.bz2
gentoo-c11fbeacd4e2f36848249fee8efc104c9f8054b7.zip
dev-python/iniparse: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iniparse')
-rw-r--r--dev-python/iniparse/iniparse-0.5_p20221102.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/iniparse/iniparse-0.5_p20221102.ebuild b/dev-python/iniparse/iniparse-0.5_p20221102.ebuild
index ed1508ff92c5..fdf3b827d469 100644
--- a/dev-python/iniparse/iniparse-0.5_p20221102.ebuild
+++ b/dev-python/iniparse/iniparse-0.5_p20221102.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -33,10 +33,18 @@ BDEPEND="
${RDEPEND}
"
-PATCHES=(
- # https://github.com/candlepin/python-iniparse/pull/29
- "${FILESDIR}/${P}-py3.11.7.patch"
-)
+src_prepare() {
+ local PATCHES=(
+ # https://github.com/candlepin/python-iniparse/pull/29
+ "${FILESDIR}/${P}-py3.11.7.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ # https://src.fedoraproject.org/rpms/python-iniparse/blob/rawhide/f/python-iniparse.spec
+ sed -e "s/unittest.makeSuite(\(.*\), 'test')/unittest.defaultTestLoader.loadTestsFromTestCase(\1)/g" \
+ -i tests/test*.py || die
+}
python_test() {
"${EPYTHON}" runtests.py -v || die