summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-23 22:48:03 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-23 23:51:29 -0600
commiteacc05da8d6ea03887d0e5eab98224e54bac5073 (patch)
tree0b90335a12b613965e545d9bcc9b5a52ec85eb01 /dev-python/ipaddress/ipaddress-1.0.19.ebuild
parentdev-python/munch: 2.2.0 bup (diff)
downloadgentoo-eacc05da8d6ea03887d0e5eab98224e54bac5073.tar.gz
gentoo-eacc05da8d6ea03887d0e5eab98224e54bac5073.tar.bz2
gentoo-eacc05da8d6ea03887d0e5eab98224e54bac5073.zip
dev-python/ipaddress: 1.0.19 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/ipaddress/ipaddress-1.0.19.ebuild')
-rw-r--r--dev-python/ipaddress/ipaddress-1.0.19.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ipaddress/ipaddress-1.0.19.ebuild b/dev-python/ipaddress/ipaddress-1.0.19.ebuild
new file mode 100644
index 000000000000..25470870e9dd
--- /dev/null
+++ b/dev-python/ipaddress/ipaddress-1.0.19.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="IPv4/IPv6 manipulation library, backport of the ipaddress module"
+HOMEPAGE="https://github.com/phihag/ipaddress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test_ipaddress.py || die
+}