summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-26 01:29:55 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-26 01:38:38 +0200
commit4d9e13786adbdb4efabc7094214288b089b534ec (patch)
tree5f4c8ba22169e1cacaf2a07f9d62d798d779aec4 /dev-python/isort
parentnet-misc/s4cmd: new package (diff)
downloadgentoo-4d9e13786adbdb4efabc7094214288b089b534ec.tar.gz
gentoo-4d9e13786adbdb4efabc7094214288b089b534ec.tar.bz2
gentoo-4d9e13786adbdb4efabc7094214288b089b534ec.zip
dev-python/isort: enable py3.10, use EPYTEST_IGNORE
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/isort-5.9.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/isort/isort-5.9.3.ebuild b/dev-python/isort/isort-5.9.3.ebuild
index d0eb4aea1628..31f30cb1538a 100644
--- a/dev-python/isort/isort-5.9.3.ebuild
+++ b/dev-python/isort/isort-5.9.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A python utility/library to sort imports"
@@ -51,9 +51,9 @@ python_test() {
popd >/dev/null || die
done
- local deselect=(
+ local EPYTEST_IGNORE=(
# Excluded from upstream's test script
tests/unit/test_deprecated_finders.py
)
- epytest tests/unit ${deselect[@]/#/--deselect }
+ epytest tests/unit
}