summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-12-31 15:58:21 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-12-31 16:18:24 +0100
commit9a7af57ee1e15a6c0c939cb52043b8d921c8125d (patch)
treea7b2004acb562229b871672f9ad32cab5fc8f269 /dev-python/jaraco-functools/jaraco-functools-3.0.0.ebuild
parentdev-python/tempora: remove old (diff)
downloadgentoo-9a7af57ee1e15a6c0c939cb52043b8d921c8125d.tar.gz
gentoo-9a7af57ee1e15a6c0c939cb52043b8d921c8125d.tar.bz2
gentoo-9a7af57ee1e15a6c0c939cb52043b8d921c8125d.zip
dev-python/jaraco-functools: bump to 3.0.0, drops Py<3.6
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-functools/jaraco-functools-3.0.0.ebuild')
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-3.0.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/jaraco-functools-3.0.0.ebuild b/dev-python/jaraco-functools/jaraco-functools-3.0.0.ebuild
new file mode 100644
index 000000000000..e3560828aca9
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-3.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+# TODO: remove six
+# https://github.com/jaraco/jaraco.functools/pull/14
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+ sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
+ setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ # note: eclass may default to --skip-build in the future
+ distutils-r1_python_install --skip-build
+}