summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 06:33:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 07:17:59 +0200
commit13fc5c1c9109e6d7e0e21ea93272d9732ac72391 (patch)
tree9af5d1ba87fa27f670f6725500e370331bd49529 /dev-python/jsonschema-spec
parentdev-python/pytest: Bump to 7.3.2 (diff)
downloadgentoo-13fc5c1c9109e6d7e0e21ea93272d9732ac72391.tar.gz
gentoo-13fc5c1c9109e6d7e0e21ea93272d9732ac72391.tar.bz2
gentoo-13fc5c1c9109e6d7e0e21ea93272d9732ac72391.zip
dev-python/jsonschema-spec: Bump to 0.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest1
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index 099dc66992ee..d769edd21b00 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1 +1,2 @@
DIST jsonschema-spec-0.1.4.gh.tar.gz 30903 BLAKE2B eae7ba8b811dfd14d9b2e33d3355bf8c98e088b1a8fa3314300dcc7edae31727cc5a01d0a06af412b8c7d59eca69ba816f6eb2683e997719fd300a3445e96cfd SHA512 6b3d1710fdd8c43a0f38d0687c95e4e70c55df964dc597e4a00abad3459610829bd90190b21c512c70d46498d98b80ecc2422eb73d7822539841ff10bc7c2c4f
+DIST jsonschema-spec-0.1.5.gh.tar.gz 36035 BLAKE2B 4e6019fb1c7f5e85a03488e00ef080798bc6e3e06999d9c9c931072c640fd74b5125882e43dca26bad1acc3bdacb06a26f2c95dff25339e3f8b785d759085a49 SHA512 c76b15a3ead9498696c80cf7a378a675194837f04cd88d81be5213a38cde8177d5e8f7866d007648b7013db74d1057b700b027a79bcd893b0d493269abcd621d
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild
new file mode 100644
index 000000000000..11106a6a143e
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/jsonschema-4.18[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ # remove impossible constraint
+ sed -i -e '/typing.extensions/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}