summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-05 04:35:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-05 04:47:33 +0100
commit3cb42f8002b12fbd4338debbd92c3efd6d5c808b (patch)
tree87ea292bf2be786a0b5ba646a5b51d21ce51607f /dev-python/jupyterlab-lsp
parentdev-python/psycopg: Bump to 3.1.18 (diff)
downloadgentoo-3cb42f8002b12fbd4338debbd92c3efd6d5c808b.tar.gz
gentoo-3cb42f8002b12fbd4338debbd92c3efd6d5c808b.tar.bz2
gentoo-3cb42f8002b12fbd4338debbd92c3efd6d5c808b.zip
dev-python/jupyterlab-lsp: Bump to 5.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 4dd670c93133..2437175a7dc4 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-lsp-5.0.1.tar.gz 755832 BLAKE2B d8082aaf9c1219fedeebd6a717b81f08a7bba2a8618dc99b2ecf9a6d28c4e6cbf34b711c4fae4a847675ea05d2dc7acd0c812a772e9d51f37f563d088398c088 SHA512 7fef1ab7309978aa9185afdc895a7adefc72210842228d055150b231b70980e772abf166762820971f653cf0f5abd65e9bdfe3a206c4aed99b4586fec684399e
DIST jupyterlab-lsp-5.0.2.tar.gz 757169 BLAKE2B e1d7b26805264c570275e021ac2c4af688c70c428b0966c4f6fb75f890be55b1543602f93e6565f6ade485bec6b3d5f8d680c73c07b3f069f25990a6ad633b2b SHA512 f2826cd4d940855814d2f7cb7a07eaf4c9fb8d8440fd1f27b381804ee2c892f00461d49166e90fb8f7aa3eae64aa873973369ba56a1e484f349aab7c05d0dbc6
+DIST jupyterlab-lsp-5.0.3.tar.gz 757263 BLAKE2B df2a3a1a1cb0a9a9345f151ae5c510056ca26868353d457b7aa4b6405041f0b4e55afba09019722a1f37592b46b1a8e53b40c8f595215f74cea29a598b029648 SHA512 20d5a3e33fbab8b5e47a10f23b12cf7e91ca5d4ac9020345e3cc973a391643cd380ff182f1109a387a7ebcced6becd1b7847a888829cb30be1f4ed536177575f
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.3.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.3.ebuild
new file mode 100644
index 000000000000..d87eafa065c7
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="
+ https://github.com/jupyter-lsp/jupyterlab-lsp/
+ https://pypi.org/project/jupyterlab-lsp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"