summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:45:58 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:52:34 +0200
commit8cda1360b19e4321daab362d0e1fda421d7e5fb1 (patch)
tree89cc7be160cbdb7ae2302bb1ff2902baaf1a8d04 /dev-python/jupyterlab-lsp
parentdev-python/jupyterlab: add 3.6.2 (diff)
downloadgentoo-8cda1360b19e4321daab362d0e1fda421d7e5fb1.tar.gz
gentoo-8cda1360b19e4321daab362d0e1fda421d7e5fb1.tar.bz2
gentoo-8cda1360b19e4321daab362d0e1fda421d7e5fb1.zip
dev-python/jupyterlab-lsp: add 4.0.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-4.0.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 32ca9b4d8328..c0cf58b834e4 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-lsp-3.10.2.tar.gz 269490 BLAKE2B 43e4c79e94f85497f83c8034d63164ae5e0820dba6a725048c7f11522d2ab98326e637c254251e96d72d35d7ff8962ab8750a2ba42681c4ef34a65bbb42240d4 SHA512 e154b1f382d2a70a3378f821b055d9a05e9ba748f3ca3e61974655ec3a06f73bc864ad18917171e1101692760fab44b830d2eb70676961a09e383b3544d8ba71
+DIST jupyterlab-lsp-4.0.1.tar.gz 869528 BLAKE2B 62df16ba8aef6c344324346501191776a0534ddf6b5acff4de477f8f7f8996f7ec78022bada4c16d582fdfb7f916fd70f6c9c176505d25c47e863aa65f681f77 SHA512 8f71a6f39bec08fab8401a7074d65fa9a4bdca66ed3c11f75777095f160e9eab25b75b21f1ea4e509f43ff0beebe777f690c13ad0325b5ee26bcd1ec301119e4
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.0.1.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.0.1.ebuild
new file mode 100644
index 000000000000..f8fbb2f8f9b2
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.6.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"