summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-23 15:37:05 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-23 15:57:11 +0100
commit88eac445f72c64cf1c297273383c877f50be0a82 (patch)
treeb50e016f9fe94482aaa66836f96e5d28d1202b02 /dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
parentdev-python/phonenumbers: Bump to 8.13.26 (diff)
downloadgentoo-88eac445f72c64cf1c297273383c877f50be0a82.tar.gz
gentoo-88eac445f72c64cf1c297273383c877f50be0a82.tar.bz2
gentoo-88eac445f72c64cf1c297273383c877f50be0a82.zip
dev-python/jupyterlab-pygments: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild')
-rw-r--r--dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild b/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
new file mode 100644
index 000000000000..011c3409a41f
--- /dev/null
+++ b/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pygments theme making use of JupyterLab CSS variables"
+HOMEPAGE="
+ https://pypi.org/project/jupyterlab-pygments/
+ https://github.com/jupyterlab/jupyterlab_pygments/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/$(pypi_wheel_name)"
+}