summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-12 19:03:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-12 19:34:04 +0200
commit1502a2c2a2437dc3da09123628ba5fc352894c1d (patch)
tree66ad5d2b1970e66d089afcd66ae73bffd709a6fa /dev-python/jupyterlab_pygments
parentdev-python/pytest-testinfra: Bump to 6.7.0 (diff)
downloadgentoo-1502a2c2a2437dc3da09123628ba5fc352894c1d.tar.gz
gentoo-1502a2c2a2437dc3da09123628ba5fc352894c1d.tar.bz2
gentoo-1502a2c2a2437dc3da09123628ba5fc352894c1d.zip
dev-python/jupyterlab_pygments: Bump to 0.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab_pygments')
-rw-r--r--dev-python/jupyterlab_pygments/Manifest1
-rw-r--r--dev-python/jupyterlab_pygments/jupyterlab_pygments-0.2.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jupyterlab_pygments/Manifest b/dev-python/jupyterlab_pygments/Manifest
index 149205024411..ca067225840d 100644
--- a/dev-python/jupyterlab_pygments/Manifest
+++ b/dev-python/jupyterlab_pygments/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab_pygments-0.1.2.tar.gz 561989 BLAKE2B 85d6b59b2c959f838746c7c6fed99ad5adda89a514a77327cc8e9ba7d6a91b1c0206d999c09149e6c5b9c67911ca16914f0b17a67b3505db73c23a7194fe4566 SHA512 0b4f4c13017f8afbd83e9fb575b3c4ee44272bc01421761ae7b140ecab743d825aa195432caa5f6153bda0ef84fe3ab92dad61ffd9b048927736a916dd267b5a
DIST jupyterlab_pygments-0.2.0.tar.gz 132386 BLAKE2B db2b1677227fc1817769aaabd7f9e559871b13a9f937e76f5912a6e99fd186b19ce136712a01c8cd6db2b246fd2e7176b897164c9084781a59eb5f72c21577a1 SHA512 0ac05c3f31e554c51e889c4bf4af6ba3f787ef152a7a7e1862ff9dc46d89418bc3567c57e42b30f3134f1b56cc9c31a6d96ef76905fdb6ee39decfa8cf388ca6
+DIST jupyterlab_pygments-0.2.1.tar.gz 144325 BLAKE2B ee3f9d9789652ee7226cff550505113a7e5f779bbf58405d699bad44455e7448b16cdf607515528f7240dbb5008b0a3b8502c23caa842bf731b5e6a54bbcf7c7 SHA512 746b490cffba3fce133d09e209939f45d7080b778d9c78feeaeb4ca4e7ba34668499bdc7ab4c70a972caa1ed4b53e0e5d788802478c6047d93b577e618214027
diff --git a/dev-python/jupyterlab_pygments/jupyterlab_pygments-0.2.1.ebuild b/dev-python/jupyterlab_pygments/jupyterlab_pygments-0.2.1.ebuild
new file mode 100644
index 000000000000..797c67662623
--- /dev/null
+++ b/dev-python/jupyterlab_pygments/jupyterlab_pygments-0.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=jupyter
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pygments theme making use of JupyterLab CSS variables"
+HOMEPAGE="
+ https://pypi.org/project/jupyterlab-pygments/
+ https://github.com/jupyterlab/jupyterlab_pygments/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+"