summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 17:02:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 17:12:33 +0100
commita4b961c7aafa1b0d85a7dd760ab8939a55c14913 (patch)
treee39b66578a10358ac59c9d2a723b2eb017414d54 /dev-python/license-expression
parentdev-python/boolean-py: New package, v3.8 (diff)
downloadgentoo-a4b961c7aafa1b0d85a7dd760ab8939a55c14913.tar.gz
gentoo-a4b961c7aafa1b0d85a7dd760ab8939a55c14913.tar.bz2
gentoo-a4b961c7aafa1b0d85a7dd760ab8939a55c14913.zip
dev-python/license-expression: New package, v21.6.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/license-expression')
-rw-r--r--dev-python/license-expression/Manifest1
-rw-r--r--dev-python/license-expression/license-expression-21.6.14.ebuild33
-rw-r--r--dev-python/license-expression/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/license-expression/Manifest b/dev-python/license-expression/Manifest
new file mode 100644
index 000000000000..24ba1af8ede5
--- /dev/null
+++ b/dev-python/license-expression/Manifest
@@ -0,0 +1 @@
+DIST license-expression-21.6.14.gh.tar.gz 107788 BLAKE2B 18e123be256df2de289b00f292782fd5010333f692ba56caea448bf9a5102d2a11868a3c85787b5cd8129a9d3f9728e0776fa7658d00efe79c124a40f2263683 SHA512 12c4333a53f30c73f123434c9e50ee50163a3bad5831e756cc1350c14daa062b939e8382f4bcf2fef11020f8bec5185f71302f3c68ae88cd59b8da9a5f2964f4
diff --git a/dev-python/license-expression/license-expression-21.6.14.ebuild b/dev-python/license-expression/license-expression-21.6.14.ebuild
new file mode 100644
index 000000000000..96779c8f4a70
--- /dev/null
+++ b/dev-python/license-expression/license-expression-21.6.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Parse, compare, simplify and normalize license expressions"
+HOMEPAGE="
+ https://pypi.org/project/license-expression/
+ https://github.com/nexB/license-expression/
+"
+SRC_URI="
+ https://github.com/nexB/license-expression/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/boolean-py-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
diff --git a/dev-python/license-expression/metadata.xml b/dev-python/license-expression/metadata.xml
new file mode 100644
index 000000000000..8bdb7d68016d
--- /dev/null
+++ b/dev-python/license-expression/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">nexB/license-expression</remote-id>
+ <remote-id type="pypi">license-expression</remote-id>
+ </upstream>
+</pkgmetadata>