summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-02-06 08:22:39 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-06 09:08:13 +0100
commitc5749ef3cce4c04c359df5bfaf0dddec71b21b00 (patch)
tree169a36dc7a9e19804eda8684a2d3f51ce422d733 /dev-python/line_profiler/line_profiler-2.0.ebuild
parentdev-scheme/guile-json: fix dep bug #608296 (diff)
downloadgentoo-c5749ef3cce4c04c359df5bfaf0dddec71b21b00.tar.gz
gentoo-c5749ef3cce4c04c359df5bfaf0dddec71b21b00.tar.bz2
gentoo-c5749ef3cce4c04c359df5bfaf0dddec71b21b00.zip
dev-python/line_profiler: Version bump to 2.0
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3784
Diffstat (limited to 'dev-python/line_profiler/line_profiler-2.0.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/line_profiler/line_profiler-2.0.ebuild b/dev-python/line_profiler/line_profiler-2.0.ebuild
new file mode 100644
index 000000000000..638f08c97974
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/rkern/line_profiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}