summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 22:08:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 22:15:50 +0300
commit77a972dfb3f767a193cb590d612a6ca5ebefd7c9 (patch)
tree82e861b179682ed4e0b7278aee663badc3c4f6a1 /dev-python/mimerender
parentdev-python/mergedict: enable py3.11 (diff)
downloadgentoo-77a972dfb3f767a193cb590d612a6ca5ebefd7c9.tar.gz
gentoo-77a972dfb3f767a193cb590d612a6ca5ebefd7c9.tar.bz2
gentoo-77a972dfb3f767a193cb590d612a6ca5ebefd7c9.zip
dev-python/mimerender: EAPI=8, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mimerender')
-rw-r--r--dev-python/mimerender/mimerender-0.6.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mimerender/mimerender-0.6.0-r1.ebuild b/dev-python/mimerender/mimerender-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..e5ec7f9a9d78
--- /dev/null
+++ b/dev-python/mimerender/mimerender-0.6.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="RESTful HTTP Content Negotiation for Flask, Bottle, web.py and webapp2"
+HOMEPAGE="
+ https://pypi.org/project/mimerender/
+ https://github.com/martinblech/mimerender/"
+SRC_URI="
+ https://github.com/martinblech/mimerender/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/python-mimeparse[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ "${EPYTHON}" src/test.py -v || die "Tests fail with ${EPYTHON}"
+}