summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-10-02 21:01:26 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-10-02 21:02:03 +0700
commita9cc2d5dde31b49dc8a1f3dad79f7ec4d7b21a43 (patch)
treebdc4db79a9be12d627a969b09c3849d2eecf19df /dev-python/mpmath
parentsys-block/thin-provisioning-tools: Stable on amd64 (diff)
downloadgentoo-a9cc2d5dde31b49dc8a1f3dad79f7ec4d7b21a43.tar.gz
gentoo-a9cc2d5dde31b49dc8a1f3dad79f7ec4d7b21a43.tar.bz2
gentoo-a9cc2d5dde31b49dc8a1f3dad79f7ec4d7b21a43.zip
dev-python/mpmath: cleaning 0.18
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/mpmath-0.18.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 710b5dcace9b..ae1ebd51797c 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,3 +1,2 @@
DIST mpmath-1.0.0.tar.gz 511349 SHA256 d32ba7afffbae688229a15f54fbc37c11f4989e4fac628c99b3c5b6889aee03d SHA512 b225f237008e1cfee52b2f0dca0dce1445b932b6eaef92879d7feca30d728e3f88810bfa80882ad8776ba846a636807e59bebe0b9f690cd878c089e9418bd8b7 WHIRLPOOL 5dc18ab6f81a529c06bcc968dd3e9da0a5123740b2a5b2829e98b303b5e3d8208956122a7fd7698ad275d4246aafcbd1756bc0922801d32a535b809cf749b3ac
-DIST mpmath-all-0.18.tar.gz 2122954 SHA256 47cc9587ea10202cdfb1afce4fb7410821e91ae6ecb1b54d62be1adfce80ee40 SHA512 a22e1c82f33a30584c975d196601e7bddaf33d4a41b1f288216a9df038ba5a45fd1002c5aa5f15084d05bee3abad944168ad131ac7e4feb218aac22789d8a63f WHIRLPOOL 7544b09310fbb262f2a4f487fa29af429196142e3fcab5822c1383420c7d8948a70b0f505adc0ce4fd7c0e6b6936b8dc6832a5e3d92e7c7cb71d05f6343dd79a
DIST mpmath-all-0.19.tar.gz 2123129 SHA256 21a824db176799f42843e4510da4bc6db36ef92b5a43fff70fad7e29bffb9c86 SHA512 5a6ed0b5fad84c1e8399467ea7a1295f9b77c8e673b821c11e3298e88df6c48d9967eed84e2979bf12868e2f9b42bffba01a0c1836a6d82ac42d5f423fed6580 WHIRLPOOL 360fedc4d6942a138b33c63867f8a5e4ce4c101a8f7221c61503933e75073807676cbb240c9bddea765159cb134efd608256c9b921b7d282763b57d2897eefdb
diff --git a/dev-python/mpmath/mpmath-0.18.ebuild b/dev-python/mpmath/mpmath-0.18.ebuild
deleted file mode 100644
index 0fca73968d17..000000000000
--- a/dev-python/mpmath/mpmath-0.18.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils
-
-MY_PN=${PN}-all
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="https://code.google.com/p/mpmath"
-SRC_URI="mirror://pypi/m/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-IUSE="doc examples gmp matplotlib test"
-
-RDEPEND="
- gmp? ( dev-python/gmpy )
- matplotlib? ( dev-python/matplotlib )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}.patch"
- )
-
- # this fails with the current version of dev-python/py
- rm ${PN}/conftest.py || die
-
- # this test requires X
- rm ${PN}/tests/test_visualization.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd doc || die
- "${PYTHON}" build.py || die "Generation of documentation failed"
- fi
-}
-
-python_test() {
- py.test -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/. )
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}