summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 14:35:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 14:35:28 +0200
commitc65808ac7ae2694d057e1ad3c29a7bd4d15f6cb5 (patch)
treea24ee236c0ba3426095adebfaaa3992f23375041 /dev-python/myst-parser
parentdev-python/filelock: Remove old (diff)
downloadgentoo-c65808ac7ae2694d057e1ad3c29a7bd4d15f6cb5.tar.gz
gentoo-c65808ac7ae2694d057e1ad3c29a7bd4d15f6cb5.tar.bz2
gentoo-c65808ac7ae2694d057e1ad3c29a7bd4d15f6cb5.zip
dev-python/myst-parser: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/myst-parser')
-rw-r--r--dev-python/myst-parser/Manifest1
-rw-r--r--dev-python/myst-parser/myst-parser-1.0.0.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/myst-parser/Manifest b/dev-python/myst-parser/Manifest
index e38139a2230b..f62ab3c5d2ac 100644
--- a/dev-python/myst-parser/Manifest
+++ b/dev-python/myst-parser/Manifest
@@ -1,2 +1 @@
-DIST MyST-Parser-1.0.0.gh.tar.gz 813309 BLAKE2B 03bc080e0a5103b9fb239cfbea991012b1fb5f411a5a6a121b2113ad7172a1130bf8b77d20ce84a8aade4148ffba36788eb95b15ecd28c53ed321226ae8600f2 SHA512 1f0ecffd2c84b0db5d251dbc771457cdf52a8e6e540d3acde563115af24ce30d43e01223f172b3e72b2c81862052bb05ea5d7c6091f933afbda0a859d1b86e83
DIST MyST-Parser-2.0.0.gh.tar.gz 815453 BLAKE2B 8f5dd823c3c79d843b45a7a4819d5677b51a12f78db2c1ce9700eb6faa8c4f0bc167fb1d8cd947e89ffab85aec947ab527b67dc73ef4db97a393f700a4331738 SHA512 c47bdd773565e93c4714d318a70f9a8adab1be6e2a63c23175667fc4afb5da4d66b84e11176782c8202e9fd68883e74d444911ddfb0b91356c2ba07fa65f7ea4
diff --git a/dev-python/myst-parser/myst-parser-1.0.0.ebuild b/dev-python/myst-parser/myst-parser-1.0.0.ebuild
deleted file mode 100644
index f6e2f9f396bc..000000000000
--- a/dev-python/myst-parser/myst-parser-1.0.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=MyST-Parser-${PV}
-DESCRIPTION="Extended commonmark compliant parser, with bridges to Sphinx"
-HOMEPAGE="
- https://github.com/executablebooks/MyST-Parser/
- https://pypi.org/project/myst-parser/
-"
-SRC_URI="
- https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- <dev-python/docutils-0.20[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markdown-it-py[${PYTHON_USEDEP}]
- >=dev-python/mdit-py-plugins-0.3.4[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- <dev-python/sphinx-7[${PYTHON_USEDEP}]
- >=dev-python/sphinx-5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/pytest-regressions[${PYTHON_USEDEP}]
- dev-python/pytest-param-files[${PYTHON_USEDEP}]
- dev-python/sphinx-pytest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Unimportant tests needing a new dep linkify
- tests/test_renderers/test_myst_config.py::test_cmdline
- tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # bad test relying on exact exception messages
- "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
- )
-
- epytest
-}