summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-28 07:02:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-28 07:13:47 +0200
commit92324f7359fede140223fb5041bfaa9e61c6bc7f (patch)
treed9ac82bde16af0374edc815a7b3e58f4a5186c41 /dev-python/nbsphinx/nbsphinx-0.9.3.ebuild
parentdev-python/mkdocs-material: Bump to 9.2.5 (diff)
downloadgentoo-92324f7359fede140223fb5041bfaa9e61c6bc7f.tar.gz
gentoo-92324f7359fede140223fb5041bfaa9e61c6bc7f.tar.bz2
gentoo-92324f7359fede140223fb5041bfaa9e61c6bc7f.zip
dev-python/nbsphinx: Bump to 0.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbsphinx/nbsphinx-0.9.3.ebuild')
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.9.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/nbsphinx-0.9.3.ebuild b/dev-python/nbsphinx/nbsphinx-0.9.3.ebuild
new file mode 100644
index 000000000000..a29963c7e93e
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"