summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-13 19:45:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-13 19:45:41 +0100
commit02a782426751505b38f3715f8e40f291dda42ed7 (patch)
tree5159e3f2025175be8bd7683750069ba72ceedbaf /dev-python/nbsphinx
parentdev-python/openstacksdk: Remove old (diff)
downloadgentoo-02a782426751505b38f3715f8e40f291dda42ed7.tar.gz
gentoo-02a782426751505b38f3715f8e40f291dda42ed7.tar.bz2
gentoo-02a782426751505b38f3715f8e40f291dda42ed7.zip
dev-python/nbsphinx: Bump to 0.8.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbsphinx')
-rw-r--r--dev-python/nbsphinx/Manifest1
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.8.10.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index 13970bb75d3a..b676a7a65228 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1 +1,2 @@
+DIST nbsphinx-0.8.10.tar.gz 177352 BLAKE2B e9fce12b59afe4b364be36ecfe4abc98e9444feafd52fa647ca2832622d875f78389928961d2c53235f466c55e9e1aee8ecf9db6751dfe7d0db8d40502876459 SHA512 a010ceff90d59d3cbff7953c1c807b9ff23661e1fb2255d5af151f6a1b4a2441f7a836a4fbea5ed11eda42ca8a0eae091ffe7d87c09940480d5f4e3311bb177b
DIST nbsphinx-0.8.9.tar.gz 177348 BLAKE2B 9571813137832a81bc5eeb0882711df0a37ee492de1c8c65aab755636d614239e9cf961d57baf0eec05b8070a915213beae5ae94cd21d1f0e1bb57726698951e SHA512 10240ea849929579d2f76a0fdf5045cc9fca7d31c05b3a4073bb7aae67446c7be807a2d1afde60396926499bd42f1a9b514f5594c457eb5070d32126e5340309
diff --git a/dev-python/nbsphinx/nbsphinx-0.8.10.ebuild b/dev-python/nbsphinx/nbsphinx-0.8.10.ebuild
new file mode 100644
index 000000000000..c39328378976
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.8.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"