summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 08:52:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 11:14:22 +0200
commitf9c3cb4e2273ee29fbd58a24f250d56a8392514f (patch)
tree126a4499514ba576d9e1f352fd20225e391b0076 /dev-python/nbsphinx
parentdev-libs/zziplib: stable 0.13.72-r1 for hppa, bug #847559 (diff)
downloadgentoo-f9c3cb4e2273ee29fbd58a24f250d56a8392514f.tar.gz
gentoo-f9c3cb4e2273ee29fbd58a24f250d56a8392514f.tar.bz2
gentoo-f9c3cb4e2273ee29fbd58a24f250d56a8392514f.zip
dev-python/nbsphinx: Bump to 0.8.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbsphinx')
-rw-r--r--dev-python/nbsphinx/Manifest1
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.8.9.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index d4956b255d7a..8ef9c118e2af 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1 +1,2 @@
DIST nbsphinx-0.8.8.tar.gz 146831 BLAKE2B 26687d74900e7667dff644a91d58eeed57e2b2e91391d4a8024d5ee2c858d5d8bb132db5b025357817004480bc161d8ad6f5c003240d6bbc23420e1633a63abd SHA512 8a791171d6fffc414e19224d29e323644e141c5c51522b7914549aa066f2757cb4e88318a1bf20e4abbd7130cf85c4e8c3fb5537802098342a32c896e3caf3bf
+DIST nbsphinx-0.8.9.tar.gz 177348 BLAKE2B 9571813137832a81bc5eeb0882711df0a37ee492de1c8c65aab755636d614239e9cf961d57baf0eec05b8070a915213beae5ae94cd21d1f0e1bb57726698951e SHA512 10240ea849929579d2f76a0fdf5045cc9fca7d31c05b3a4073bb7aae67446c7be807a2d1afde60396926499bd42f1a9b514f5594c457eb5070d32126e5340309
diff --git a/dev-python/nbsphinx/nbsphinx-0.8.9.ebuild b/dev-python/nbsphinx/nbsphinx-0.8.9.ebuild
new file mode 100644
index 000000000000..b4b9f9e97832
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.8.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"