summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-11 20:55:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-11 21:10:08 +0200
commit8fc6b4bdb33e025addfeb8452be8846f835706fb (patch)
tree87305642a21f33b7f22b1afc7765957977a3bc62 /dev-python/numexpr
parentdev-python/pikepdf: add 4.2.0 (diff)
downloadgentoo-8fc6b4bdb33e025addfeb8452be8846f835706fb.tar.gz
gentoo-8fc6b4bdb33e025addfeb8452be8846f835706fb.tar.bz2
gentoo-8fc6b4bdb33e025addfeb8452be8846f835706fb.zip
dev-python/numexpr: add 2.8.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.8.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 21f5a340b447..f57f9f1f534b 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,2 +1,3 @@
DIST numexpr-2.7.3.tar.gz 114113 BLAKE2B 95dca4fbd3148bbf198f82827a63fac3e9de29f677457f2ad45040e24a38bb05e4e09738efa0cac793970e18bdcd252e2744da96062217fd35b4054b10112989 SHA512 8234a65ce96ea0a2f20cce7dce3de652362a9edc86af2e7a333cdd8ecd87866f75970859ff39b04d529acc062b806cc8c64f262c318edd2897200d7e54b429e7
DIST numexpr-2.8.0.tar.gz 111765 BLAKE2B 20b56ce6b5c83a72c317c1b03c1084f64a2438deaeaf73a97afc8ab75abe0d3aa3721df8e7921568ff14c36fc0737e87be82951d1911f2eedee8f0e9fcad2fb8 SHA512 33f54eed99cab552c868cc5091ea76e13da12367507161713304f48b322289a01aeabe750f13501cc5654c6068c7e6220c6adeb8703fef174a445860f142614f
+DIST numexpr-2.8.1.tar.gz 111984 BLAKE2B b5d0b5bd5507c8c513db6404917b6256d9c8d232ea5d2f027f42cdac4a5e5c5f8c2db3d2283734f80d0ae7df2551314d088ccd2ed8e2c7401cc04a15ad61751d SHA512 243cddcb1fece9410e35c87a4c3f794ac0963ddfcc054b9a9c9842a2bb4e782d6c939f532d00d724d4b447d915764c3c8bbb87a99c71a22951798329aa7494bd
diff --git a/dev-python/numexpr/numexpr-2.8.1.ebuild b/dev-python/numexpr/numexpr-2.8.1.ebuild
new file mode 100644
index 000000000000..1e6ee29f7c87
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
+ import sys,numexpr
+ sys.exit(0 if numexpr.test().wasSuccessful() else 1)
+ EOF
+ pushd >/dev/null || die
+}