summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-13 15:58:05 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-13 16:01:52 +0100
commit4497facdc05ae843c1b0797936ef0945a9e0ac14 (patch)
treebd080cc8ab4b657ffdd51a2f92fe2073968fecf9 /dev-python/objgraph
parentdev-python/tomlkit: Remove old (diff)
downloadgentoo-4497facdc05ae843c1b0797936ef0945a9e0ac14.tar.gz
gentoo-4497facdc05ae843c1b0797936ef0945a9e0ac14.tar.bz2
gentoo-4497facdc05ae843c1b0797936ef0945a9e0ac14.zip
dev-python/objgraph: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/objgraph')
-rw-r--r--dev-python/objgraph/Manifest1
-rw-r--r--dev-python/objgraph/files/objgraph-3.4.1-tests.patch57
-rw-r--r--dev-python/objgraph/objgraph-3.5.0-r1.ebuild46
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/objgraph/Manifest b/dev-python/objgraph/Manifest
index 13e9be0bb419..94b9ed464945 100644
--- a/dev-python/objgraph/Manifest
+++ b/dev-python/objgraph/Manifest
@@ -1,2 +1 @@
-DIST objgraph-3.5.0.tar.gz 638591 BLAKE2B 7a0ee6c9ee1d8417f7b322f19a397ea2452ed592ebbc07afc1378e86b5bad3895ed2e4a20d92a5f4b0215f68fc7440f85852303585a3161497a85d41d4c4e550 SHA512 da29202871bad06f2caa9cc297e7bf9a15af4c89e23baf9c271764e0ce93ff9557cd5c21d0bf39b425713460dbe2dbc8468d70c6bfcc1c3ff8b1b4d4a7923858
DIST objgraph-3.6.1.tar.gz 759513 BLAKE2B 875a4027b79446302755d00296ce0ae59d267f3996f206c8319a93cc8d5f53a0f26cf4701047d3b03beb3906bc5d70c23cdecfc135204d9fd9fea55d85e07a65 SHA512 9a15340aedb31e849739ec0667fefb52f99a94244540a7e1c0387299ad5fbbde05521ea91b959bc96204c4a62f796183377c6031af9c6a67828a91939f15225a
diff --git a/dev-python/objgraph/files/objgraph-3.4.1-tests.patch b/dev-python/objgraph/files/objgraph-3.4.1-tests.patch
deleted file mode 100644
index d79b78fb88b5..000000000000
--- a/dev-python/objgraph/files/objgraph-3.4.1-tests.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff --git a/tests.py b/tests.py
-index fc2ee7f..d494470 100755
---- a/tests.py
-+++ b/tests.py
-@@ -11,6 +11,7 @@ import tempfile
- import textwrap
- import types
- import unittest
-+import platform
-
- # setuptools imports `imp`, which triggers a DeprecationWarning starting with
- # Python 3.4 in the middle of my pristine test suite. But if I do the import
-@@ -363,7 +364,7 @@ def doctest_get_new_ids_prints():
- ========================================================
- Type Old_ids Current_ids New_ids Count_Deltas
- ========================================================
-- list ... ... ... +2
-+ wt ... ... ... +2
- ========================================================
-
- """
-@@ -387,7 +388,10 @@ class ByTypeTest(GarbageCollectedMixin, unittest.TestCase):
- # 2. the `res` list
- # referrers we don't want:
- # the ``objects`` list in the now-dead stack frame of objgraph.by_type
-- self.assertLessEqual(len(gc.get_referrers(res[0])), 2)
-+ if 'pypy' in platform.python_implementation().lower():
-+ self.assertLessEqual(len(gc.get_referrers(res[0])), 3)
-+ else:
-+ self.assertLessEqual(len(gc.get_referrers(res[0])), 2)
-
-
- class AtAddrsTest(unittest.TestCase):
-@@ -439,7 +443,10 @@ class StringRepresentationTest(GarbageCollectedMixin,
- obj = MyClass()
- with mock.patch.object(obj, 'my_method',
- types.MethodType(mock_method, obj)):
-- self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-+ if 'pypy' in platform.python_implementation().lower():
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<bound method')
-+ else:
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-
- def test_short_repr_mocked_name(self):
- self.assertRegex(objgraph._short_repr(mock.Mock(__name__=mock.Mock())),
-@@ -462,7 +469,10 @@ class StringRepresentationTest(GarbageCollectedMixin,
- obj = MyClass()
- with mock.patch.object(obj, 'my_method',
- types.MethodType(mock_method, obj)):
-- self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-+ if 'pypy' in platform.python_implementation().lower():
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<bound method')
-+ else:
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-
- @skipIf(sys.version_info[0] > 2, "Python 3 has no unbound methods")
- def test_short_repr_unbound_method(self):
diff --git a/dev-python/objgraph/objgraph-3.5.0-r1.ebuild b/dev-python/objgraph/objgraph-3.5.0-r1.ebuild
deleted file mode 100644
index 4f3489261c53..000000000000
--- a/dev-python/objgraph/objgraph-3.5.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Draws Python object reference graphs with graphviz"
-HOMEPAGE="
- https://github.com/mgedmin/objgraph/
- https://pypi.org/project/objgraph/
-"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="
- media-gfx/graphviz
-"
-BDEPEND="
- test? (
- media-gfx/xdot
- )
-"
-
-PATCHES=(
- "${FILESDIR}/objgraph-3.4.1-tests.patch"
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # the dependency is optional, actually
- sed -i -e '/graphviz/d' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/* )
- distutils-r1_python_install_all
-}