summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-09 04:17:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-09 05:26:37 +0200
commit2b3a59a692226ef6e513adca4ccb30d2ab3edc7c (patch)
treefd41132ccebb68564d49b5336e5a29beb25f0d9d /dev-python/oslo-utils
parentdev-python/zeroconf: Bump to 0.71.0 (diff)
downloadgentoo-2b3a59a692226ef6e513adca4ccb30d2ab3edc7c.tar.gz
gentoo-2b3a59a692226ef6e513adca4ccb30d2ab3edc7c.tar.bz2
gentoo-2b3a59a692226ef6e513adca4ccb30d2ab3edc7c.zip
dev-python/oslo-utils: Strip tzdata requirement
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-utils')
-rw-r--r--dev-python/oslo-utils/oslo-utils-6.2.0-r1.ebuild (renamed from dev-python/oslo-utils/oslo-utils-6.2.0.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/oslo-utils-6.2.0.ebuild b/dev-python/oslo-utils/oslo-utils-6.2.0-r1.ebuild
index c889c6445f5f..f71d5c7f6d24 100644
--- a/dev-python/oslo-utils/oslo-utils-6.2.0.ebuild
+++ b/dev-python/oslo-utils/oslo-utils-6.2.0-r1.ebuild
@@ -45,6 +45,11 @@ BDEPEND="
distutils_enable_tests unittest
+src_prepare() {
+ sed -i -e '/tzdata/d' requirements.txt || die
+ distutils-r1_src_prepare
+}
+
python_compile() {
distutils-r1_python_compile
find "${BUILD_DIR}"/install -name '*eventletutils*' -delete || die