summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-26 14:14:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-26 14:19:21 +0200
commit0913d55376f6ecdf5d07c23d11a4495466e75eb1 (patch)
tree7dabffe87892ec672d33ff71f2acfecd653df6b0 /dev-python/outcome
parentdev-python/setuptools-rust: Bump to 1.8.0 (diff)
downloadgentoo-0913d55376f6ecdf5d07c23d11a4495466e75eb1.tar.gz
gentoo-0913d55376f6ecdf5d07c23d11a4495466e75eb1.tar.bz2
gentoo-0913d55376f6ecdf5d07c23d11a4495466e75eb1.zip
dev-python/outcome: Bump to 1.3.0_p0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/outcome')
-rw-r--r--dev-python/outcome/Manifest1
-rw-r--r--dev-python/outcome/outcome-1.3.0_p0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/outcome/Manifest b/dev-python/outcome/Manifest
index d345ce0a0da7..8fb85517cb35 100644
--- a/dev-python/outcome/Manifest
+++ b/dev-python/outcome/Manifest
@@ -1,2 +1,3 @@
DIST outcome-1.2.0.gh.tar.gz 18147 BLAKE2B 19e99c8beb1c537a15040211e2fb2f30e425dbb6c81225f2b44720d52e26d8065f434949cd22f97d3a44b64d404077118842a7c85d38f1b7b01ec60d26ddaa39 SHA512 ac8f8738b000e50ace5fbf2c373c9d28f05e88fe40a11602dbb08c48d369f28651ca6c1269ce9ba4ebf1aa9701525e966c061f75313d8650e739934e3ad15003
DIST outcome-1.3.0.gh.tar.gz 20685 BLAKE2B 5bc6bd82a855cdd009b5613bcdf371d7f946b58567c436ec89db4511fa17ac15508498bfac90ec4ee4e1e60abe80f662c1e75f6da03ca087cca2264988a0b488 SHA512 0f8278db3dee0c15f82b08a172a6b1b2f360f5bd91d894338b24c6eb38884bf59f0a18d29af51b87857c41b25a81079fbffd87190392002ec9250c2d97b71965
+DIST outcome-1.3.0.post0.gh.tar.gz 20749 BLAKE2B d094f1c7c67b890fff20b81ee77d9b06616e0e3e89ce62b3936b6d2a6964cc95355f81feb82acf8d9a3f63c6af4b219bc4abafe1c329d2a5963936a9d3a7a827 SHA512 d01f6d74e883b112cd589f9e8ed05770db9b1f9ae48e84e2cbb1138c33c1496d3bae559e2627a4fe736496740866c1a9589cfc611d1c8218add1ad27f8f033ed
diff --git a/dev-python/outcome/outcome-1.3.0_p0.ebuild b/dev-python/outcome/outcome-1.3.0_p0.ebuild
new file mode 100644
index 000000000000..b04944710329
--- /dev/null
+++ b/dev-python/outcome/outcome-1.3.0_p0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Capture the outcome of Python function calls"
+HOMEPAGE="
+ https://github.com/python-trio/outcome/
+ https://pypi.org/project/outcome/
+"
+SRC_URI="
+ https://github.com/python-trio/outcome/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx-rtd-theme