summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 18:44:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 19:54:32 +0200
commit80321a33ced9bfe5edd55302e27c8d9091351ce8 (patch)
tree9c7494ae5fff9e4c77a9387bf81b8e43a4986e9f /dev-python/pathspec
parentdev-python/platformdirs: Keyword 2.5.2 s390, #843617 (diff)
downloadgentoo-80321a33ced9bfe5edd55302e27c8d9091351ce8.tar.gz
gentoo-80321a33ced9bfe5edd55302e27c8d9091351ce8.tar.bz2
gentoo-80321a33ced9bfe5edd55302e27c8d9091351ce8.zip
dev-python/pathspec: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pathspec')
-rw-r--r--dev-python/pathspec/pathspec-0.9.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pathspec/pathspec-0.9.0-r1.ebuild b/dev-python/pathspec/pathspec-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..0eaf953c1698
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.9.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths"
+HOMEPAGE="
+ https://github.com/cpburnz/python-path-specification/
+ https://pypi.org/project/pathspec/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests unittest