summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-21 20:34:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-21 20:41:10 +0300
commitb956f89cc2ae0c1b51342fd772475583caa277a7 (patch)
treefc24d97b15f66974f918639953289e4ca554791f /dev-python/pathvalidate/pathvalidate-2.5.2.ebuild
parentdev-python/textdistance: add 4.4.0 (diff)
downloadgentoo-b956f89cc2ae0c1b51342fd772475583caa277a7.tar.gz
gentoo-b956f89cc2ae0c1b51342fd772475583caa277a7.tar.bz2
gentoo-b956f89cc2ae0c1b51342fd772475583caa277a7.zip
dev-python/pathvalidate: add 2.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pathvalidate/pathvalidate-2.5.2.ebuild')
-rw-r--r--dev-python/pathvalidate/pathvalidate-2.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pathvalidate/pathvalidate-2.5.2.ebuild b/dev-python/pathvalidate/pathvalidate-2.5.2.ebuild
new file mode 100644
index 000000000000..642f62299d11
--- /dev/null
+++ b/dev-python/pathvalidate/pathvalidate-2.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library to sanitize/validate a string such as filenames/file-paths/etc"
+HOMEPAGE="https://github.com/thombashi/pathvalidate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/allpairspy[${PYTHON_USEDEP}]
+ dev-python/tcolorpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest