summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 19:58:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 20:06:16 +0200
commit60944e9b30e409f3e538b301d41dcb711b91a41b (patch)
tree379e95f712bb7e28331a7f36460f86d1207e34da /dev-python/pep517/pep517-0.12.0-r1.ebuild
parentdev-python/tomli-w: Enable py3.11 (diff)
downloadgentoo-60944e9b30e409f3e538b301d41dcb711b91a41b.tar.gz
gentoo-60944e9b30e409f3e538b301d41dcb711b91a41b.tar.bz2
gentoo-60944e9b30e409f3e538b301d41dcb711b91a41b.zip
dev-python/pep517: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pep517/pep517-0.12.0-r1.ebuild')
-rw-r--r--dev-python/pep517/pep517-0.12.0-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/pep517/pep517-0.12.0-r1.ebuild b/dev-python/pep517/pep517-0.12.0-r1.ebuild
index 222ca99b9770..1aa58f9baf68 100644
--- a/dev-python/pep517/pep517-0.12.0-r1.ebuild
+++ b/dev-python/pep517/pep517-0.12.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -12,21 +12,25 @@ DESCRIPTION="Wrappers to build Python packages using PEP 517 hooks"
HOMEPAGE="
https://pypi.org/project/pep517/
https://github.com/pypa/pep517/
- https://pep517.readthedocs.io/"
+ https://pep517.readthedocs.io/
+"
SRC_URI="
https://github.com/pypa/pep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
- dev-python/tomli[${PYTHON_USEDEP}]"
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
dev-python/testpath[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest