summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-16 12:04:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-16 12:04:52 +0300
commitdfd26d799a025dd87854781ab41c9691df3554b9 (patch)
tree9b3719c6a53442dec3ef360b8778323ed440c307 /dev-python/pikepdf
parentmedia-plugins/gst-plugins-srtp: Stabilize 1.20.3 arm64, #867784 (diff)
downloadgentoo-dfd26d799a025dd87854781ab41c9691df3554b9.tar.gz
gentoo-dfd26d799a025dd87854781ab41c9691df3554b9.tar.bz2
gentoo-dfd26d799a025dd87854781ab41c9691df3554b9.zip
dev-python/pikepdf: add 6.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-6.0.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 08718c5b85ce..ac772624f664 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -3,3 +3,4 @@ DIST pikepdf-5.5.0.gh.tar.gz 2901781 BLAKE2B 8bc04627b781a65965c0679f2cccc8c7849
DIST pikepdf-5.6.0.gh.tar.gz 2904572 BLAKE2B c248eb44d7b093029dcc0b84be64bb361dab50eaf6ee91dc4a9d95dd645266243d44e2f2f96496d2ea3f2a92e7cbee5ec48a545f8e640e15fae87ff86c1ed973 SHA512 dd579c43c4e6186fa07b7e8bbdc8f65afc7b8b4063ae65eab2b0e986d7f2db38a0a71de73efad2a7d691af2d300f85076fc3ea61ed9c6b40265d53b4bdaa6133
DIST pikepdf-5.6.1.gh.tar.gz 2905150 BLAKE2B 35c06251debb935b88f13e27f42f80b36275575d7848409bb19fa380be7429b785b8fea36e7d882a49df2e40e6c34fcc3d900b1b362f5ccf600780291f43d1f7 SHA512 add8edb16cba2081c479739ec215dc8c96a1896a159febb5bc2f74c2da1e8cf83b12a1302e1ad2ce8ab6fbf01a16104f8efb9c7a764fa1eedbc795dc45a71dfe
DIST pikepdf-6.0.0_p2.gh.tar.gz 2905192 BLAKE2B d17c3a7c414a02f4936a80dd5caa7d7f37ac97f9d57a2cf16a4af8b3bd3fd5dafdead940b85b2213cf7565ee8f45fb4894380ce9412118fb8510185c91d891c6 SHA512 efd99c6d50594d074bfb4ef4f10dbd37c88df5e80a94f41782875618596bdb43cb03645ffeedac9c4c1c9df520fade9f96d1e5695bfba6ed30f77653832b9f88
+DIST pikepdf-6.0.1.gh.tar.gz 2905054 BLAKE2B 8f633b6c359fd912a5ee2af52050e46ddc8b593ed70b8f5730fc6db8244f2ad630b175e6c2391d600e8229820dbd6dfbf52cc19124a6a69fa8e25fbc62a6c6c0 SHA512 9b44f94b5354b21036d5e6cd84d8a90b0193f63f0fe8e3e19b59febb4450380ea69a59a62af8ffec185a7ecd0542d3fcce926756c648ddb20552ed0762972193
diff --git a/dev-python/pikepdf/pikepdf-6.0.1.ebuild b/dev-python/pikepdf/pikepdf-6.0.1.ebuild
new file mode 100644
index 000000000000..7d4273098ccf
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-6.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="
+ https://github.com/pikepdf/pikepdf/
+ https://pypi.org/project/pikepdf/
+"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-text/qpdf-11.0.0:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/-n auto/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}