summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 10:32:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 10:36:07 +0200
commit71144f18904771559c8fe835266c0517bf8e6f66 (patch)
tree81b91836be9142727faf405a89404cf9ed800dd4 /dev-python/pip/files
parentdev-python/aiorpcX: Remove old (diff)
downloadgentoo-71144f18904771559c8fe835266c0517bf8e6f66.tar.gz
gentoo-71144f18904771559c8fe835266c0517bf8e6f66.tar.bz2
gentoo-71144f18904771559c8fe835266c0517bf8e6f66.zip
dev-python/pip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip/files')
-rw-r--r--dev-python/pip/files/pip-19.3-disable-version-check.patch24
-rw-r--r--dev-python/pip/files/pip-21.0-no-coverage.patch53
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/pip/files/pip-19.3-disable-version-check.patch b/dev-python/pip/files/pip-19.3-disable-version-check.patch
deleted file mode 100644
index e8fe868431d1..000000000000
--- a/dev-python/pip/files/pip-19.3-disable-version-check.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/src/pip/_internal/cli/req_command.py b/src/pip/_internal/cli/req_command.py
-index 203e86a4..a2183f10 100644
---- a/src/pip/_internal/cli/req_command.py
-+++ b/src/pip/_internal/cli/req_command.py
-@@ -129,17 +129,8 @@ class IndexGroupCommand(Command, SessionCommandMixin):
- # Make sure the index_group options are present.
- assert hasattr(options, 'no_index')
-
-- if options.disable_pip_version_check or options.no_index:
-- return
--
-- # Otherwise, check if we're using the latest version of pip available.
-- session = self._build_session(
-- options,
-- retries=0,
-- timeout=min(5, options.timeout)
-- )
-- with session:
-- pip_self_version_check(session, options)
-+ # Disabled on Gentoo
-+ return
-
-
- class RequirementCommand(IndexGroupCommand):
diff --git a/dev-python/pip/files/pip-21.0-no-coverage.patch b/dev-python/pip/files/pip-21.0-no-coverage.patch
deleted file mode 100644
index 82e3e1b30f77..000000000000
--- a/dev-python/pip/files/pip-21.0-no-coverage.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 7f61ba983025cbfab7b7b810b13f1a89cb503568 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 29 Jul 2020 07:42:25 +0200
-Subject: [PATCH] Disable coverage testing support inside test venvs
-
----
- tests/conftest.py | 16 +---------------
- 1 file changed, 1 insertion(+), 15 deletions(-)
-
-diff --git a/tests/conftest.py b/tests/conftest.py
-index 0bb69dae6..02da6c573 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -311,13 +311,6 @@ def wheel_install(tmpdir_factory, common_wheels):
- 'wheel')
-
-
--@pytest.fixture(scope='session')
--def coverage_install(tmpdir_factory, common_wheels):
-- return _common_wheel_editable_install(tmpdir_factory,
-- common_wheels,
-- 'coverage')
--
--
- def install_egg_link(venv, project_name, egg_info_dir):
- with open(venv.site / 'easy-install.pth', 'a') as fp:
- fp.write(str(egg_info_dir.resolve()) + '\n')
-@@ -327,7 +320,7 @@ def install_egg_link(venv, project_name, egg_info_dir):
-
- @pytest.fixture(scope='session')
- def virtualenv_template(request, tmpdir_factory, pip_src,
-- setuptools_install, coverage_install):
-+ setuptools_install, common_wheels):
-
- if request.config.getoption('--use-venv'):
- venv_type = 'venv'
-@@ -351,13 +344,6 @@ def virtualenv_template(request, tmpdir_factory, pip_src,
- subprocess.check_call([venv.bin / 'python', 'setup.py', '-q', 'develop'],
- cwd=pip_editable)
-
-- # Install coverage and pth file for executing it in any spawned processes
-- # in this virtual environment.
-- install_egg_link(venv, 'coverage', coverage_install)
-- # zz prefix ensures the file is after easy-install.pth.
-- with open(venv.site / 'zz-coverage-helper.pth', 'a') as f:
-- f.write('import coverage; coverage.process_startup()')
--
- # Drop (non-relocatable) launchers.
- for exe in os.listdir(venv.bin):
- if not (
---
-2.30.0
-