summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-17 18:37:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-17 18:53:56 +0200
commit4cff459ef232870887c5ebb62fc3a5bf4e9f36aa (patch)
treefdb9ab3798215a08c655bdaaeca7002196d42bf5 /dev-python/pip
parentdev-python/redis-py: drop 4.2.0, 4.2.1 (diff)
downloadgentoo-4cff459ef232870887c5ebb62fc3a5bf4e9f36aa.tar.gz
gentoo-4cff459ef232870887c5ebb62fc3a5bf4e9f36aa.tar.bz2
gentoo-4cff459ef232870887c5ebb62fc3a5bf4e9f36aa.zip
dev-python/pip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/pip-22.0.3.ebuild145
2 files changed, 0 insertions, 146 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 3a4f6666bd1e..03bd9c69113b 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,4 +1,3 @@
-DIST pip-22.0.3.tar.gz 9290286 BLAKE2B f81140fbff5d16e8a38d21047dd790be2287b664b130d43e71c7d4f23d6a7cd5c8b2e58f988cc18dc4d08b83b0fcb3eac6b6ec001421e83e35db74f15d6c557e SHA512 05f0807b298c2136842ad1cae3b003f81d85ca79103f12171e4c8d020d6add076848c1acfb6442c4ae2da6b834de0e87dffaec7bd24dfc403372cead94949326
DIST pip-22.0.4.tar.gz 9325766 BLAKE2B 9ce5a25e6fb9aedc39e2cddab2a8af3b47dbaaaf8bd22c39f8301b784e6e9f5434f63d5ef467f4d819b15bcd5cf8d3da52db34b3514c7b4a15823f77cb47e1c1 SHA512 af6d1787b4fe97f2eec9c2e3e3f0f756efca8cb83f6ecdae797986fb6050ee60d872a8a8eb7502a32c4334fc0c7af8cf3c58ce980407d0e9f89eec28a4290093
DIST setuptools-57.4.0-py3-none-any.whl 819017 BLAKE2B afba86cf9aeea58ee869fdc11bbb192abbf2f89710e468b90dc291fec228ca16202483e36195a5ad4e2b8d210326bc83e2be6ec696ab413d94ffaeb05bb9c030 SHA512 9bf230f4e0e72acab07ab372a6ca05adb3d175a8079d2f73d327c632f3d27b8ee10442d3e60f4c94a6e61d5ba2212fc78187ca6e1717e15bb570bdce4263fd0b
DIST virtualenv-16.7.11.tar.gz 8134533 BLAKE2B ea81e11c210d911bf9576edf7b1754721b270adcc5d9633415d33b8f659149d64932fe2d366200121ec00c266c25dae380e248add438fc357477114eba4dfb4e SHA512 82d0d2a964508511e8e1686703581ff543f65791dc2449d9741d46ea57c4c89673947d2477ba374176f05fcea2a5ca572aa650c61c4f3271c4d73d1ff9d9ff42
diff --git a/dev-python/pip/pip-22.0.3.ebuild b/dev-python/pip/pip-22.0.3.ebuild
deleted file mode 100644
index 1e7e51ed6bd0..000000000000
--- a/dev-python/pip/pip-22.0.3.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit bash-completion-r1 distutils-r1
-
-# setuptools & wheel .whl files are required for testing,
-# the exact version is not very important.
-SETUPTOOLS_WHL="setuptools-57.4.0-py3-none-any.whl"
-WHEEL_WHL="wheel-0.36.2-py2.py3-none-any.whl"
-# upstream still requires virtualenv-16 for testing, we are now fetching
-# it directly to avoid blockers with virtualenv-20
-VENV_PV=16.7.11
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="
- https://pip.pypa.io/en/stable/
- https://pypi.org/project/pip/
- https://github.com/pypa/pip/"
-SRC_URI="
- https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- test? (
- https://files.pythonhosted.org/packages/py3/s/setuptools/${SETUPTOOLS_WHL}
- https://files.pythonhosted.org/packages/py2.py3/w/wheel/${WHEEL_WHL}
- https://github.com/pypa/virtualenv/archive/${VENV_PV}.tar.gz
- -> virtualenv-${VENV_PV}.tar.gz
- )
-"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86"
-SLOT="0"
-IUSE="test vanilla"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/scripttest[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- !alpha? ( !hppa? ( !ia64? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- ) ) )
- )
-"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-21.3-no-coverage.patch"
- )
- if ! use vanilla; then
- PATCHES+=( "${FILESDIR}/pip-20.0.2-disable-system-install.patch" )
- fi
-
- distutils-r1_python_prepare_all
-
- if use test; then
- mkdir tests/data/common_wheels/ || die
- cp "${DISTDIR}"/{${SETUPTOOLS_WHL},${WHEEL_WHL}} \
- tests/data/common_wheels/ || die
- fi
-}
-
-python_test() {
- if [[ ${EPYTHON} == pypy* ]]; then
- ewarn "Skipping tests on ${EPYTHON} since they are very broken"
- return 0
- fi
-
- local EPYTEST_DESELECT=(
- tests/functional/test_install.py::test_double_install_fail
- tests/functional/test_list.py::test_multiple_exclude_and_normalization
- 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-download]'
- 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-install]'
- 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-list]'
- 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-wheel]'
- tests/functional/test_install.py::test_install_pip_does_not_modify_pip_when_satisfied
- # Internet
- tests/functional/test_install.py::test_install_editable_with_prefix_setup_cfg
- tests/functional/test_install.py::test_editable_install__local_dir_no_setup_py_with_pyproject
- tests/functional/test_install.py::test_editable_install__local_dir_setup_requires_with_pyproject
- )
-
- [[ ${EPYTHON} == python3.10 ]] && EPYTEST_DESELECT+=(
- tests/lib/test_lib.py::test_correct_pip_version
- # uses vendored packaging that uses deprecated distutils
- tests/functional/test_warning.py::test_pip_works_with_warnings_as_errors
- )
-
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- tests/functional/test_install.py::test_install_sends_client_cert
- tests/functional/test_install_config.py::test_do_not_prompt_for_authentication
- tests/functional/test_install_config.py::test_prompt_for_authentication
- tests/functional/test_install_config.py::test_prompt_for_keyring_if_needed
- )
- fi
-
- distutils_install_for_testing
- pushd "${WORKDIR}/virtualenv-${VENV_PV}" >/dev/null || die
- distutils_install_for_testing
- popd >/dev/null || die
- # prevent it from being installed
- rm -r "${BUILD_DIR}"/lib/virtualenv* || die
-
- local -x GENTOO_PIP_TESTING=1 \
- PATH="${TEST_DIR}/scripts:${PATH}" \
- PYTHONPATH="${TEST_DIR}/lib:${BUILD_DIR}/lib"
- epytest -m "not network"
-}
-
-python_install_all() {
- # Prevent dbus auto-launch
- # https://bugs.gentoo.org/692178
- export DBUS_SESSION_BUS_ADDRESS="disabled:"
-
- local DOCS=( AUTHORS.txt docs/html/**/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- # 'pip completion' command embeds full $0 into completion script, which confuses
- # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
- # This trick sets correct $0 while still calling just installed pip.
- local pipcmd='import sys; sys.argv[0] = "pip"; __file__ = ""; from pip._internal.cli.main import main; sys.exit(main())'
-
- "${EPYTHON}" -c "${pipcmd}" completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- "${EPYTHON}" -c "${pipcmd}" completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}