summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 17:31:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 17:31:16 +0100
commit47ccdfaf8e10c412652f6cf9870100ffe0914b7f (patch)
treea90bf4d5779785ed3dd56355c2e8dd4578c56d76 /dev-python/pkgcraft
parentdev-python/pelican-minify: Remove old (diff)
downloadgentoo-47ccdfaf8e10c412652f6cf9870100ffe0914b7f.tar.gz
gentoo-47ccdfaf8e10c412652f6cf9870100ffe0914b7f.tar.bz2
gentoo-47ccdfaf8e10c412652f6cf9870100ffe0914b7f.zip
dev-python/pkgcraft: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/Manifest2
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.3.ebuild74
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.4.ebuild76
3 files changed, 0 insertions, 152 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index c3b0a862a650..682de2ec73a3 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1,3 +1 @@
-DIST pkgcraft-0.0.3.tar.gz 1239742 BLAKE2B c9148d3ac34d80c47db5d1080b3806e6b64fffa226d595a11499215626342286efc19b86fd1e158a8ca0021ab8946d35e4393fceaf8a318c258114a6c2e1ffdf SHA512 53ae196d073271654807ef5587c38d83e10b606f59baf63e3c8da7ce1b1d80d7acd1e3e201ebba1346c14d101eded666d6ad9bdf972b36c574c9b494147baa4a
-DIST pkgcraft-0.0.4.tar.gz 397121 BLAKE2B 72b24d34b6c3b6114a5d182b4fe562078aa258a21271b33d8858c85cca480a932afab5933978295fd44d531146d58688391efe8e23f358332de83ae5195d68fb SHA512 04996bcbe6d9a8ae6082ea84a63358f42d3a503f1e0d188b627b033b8379cf6e22f5ae8ff764b7213fe6d801a1eeb6321b02967e77d98575125e16781d9b917c
DIST pkgcraft-0.0.5.tar.gz 400237 BLAKE2B de78c1570ce8080742d3afbff2c9078b56fb14e7b097bd09b47c5b21a5de1062989835c9c12e4efd9d4be4aef7e9dec1350606700d80c5482cf81d1d2c4febc0 SHA512 2366180189314cafa4be8a180eed62a8c994bfd862ebc5292e01d9cd2585b9eca082535e405924ad758d6f89309c5e64727242a52f95f6e71aa6aff3495edd57
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.3.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.3.ebuild
deleted file mode 100644
index d4fd63823f77..000000000000
--- a/dev-python/pkgcraft/pkgcraft-0.0.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for pkgcraft"
-HOMEPAGE="
- https://pypi.org/project/pkgcraft/
- https://github.com/pkgcraft/pkgcraft-python
-"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
- inherit git-r3
-
- PKGCRAFT_VERSION_MIN="9999"
- PKGCRAFT_VERSION_MAX="9999"
-else
- SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
- S="${WORKDIR}"/${P/-python}
-
- KEYWORDS="~amd64"
-
- PKGCRAFT_VERSION_MIN="0.0.4"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+examples"
-
-RDEPEND="
- >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/cython
- dev-python/setuptools-scm
- virtual/pkgconfig
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if [[ ${PV} != 9999 ]] ; then
- local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
- if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
- die "Mismatch between setup.py's MIN_VERSION and ebuild!"
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install() {
- # Conditional because these aren't installed officially right now
- # and the naming is just for convenience.
- if use examples ; then
- while IFS= read -r -d '' file ; do
- python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
- done < <(find "${S}"/examples -type f -executable -print0 || die)
- fi
-
- distutils-r1_python_install
-}
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.4.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.4.ebuild
deleted file mode 100644
index ecc27295afcc..000000000000
--- a/dev-python/pkgcraft/pkgcraft-0.0.4.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for pkgcraft"
-HOMEPAGE="
- https://pypi.org/project/pkgcraft/
- https://github.com/pkgcraft/pkgcraft-python
-"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
- inherit git-r3
-
- PKGCRAFT_VERSION_MIN="9999"
- PKGCRAFT_VERSION_MAX="9999"
-else
- SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
- S="${WORKDIR}"/${P/-python}
-
- KEYWORDS="~amd64"
-
- PKGCRAFT_VERSION_MIN="0.0.5"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+examples"
-
-RDEPEND="
- >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/cython
- dev-python/setuptools-scm
- virtual/pkgconfig
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if [[ ${PV} != 9999 ]] ; then
- local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
- if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
- eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
- eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
- die "Mismatch between setup.py's MIN_VERSION and ebuild!"
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install() {
- # Conditional because these aren't installed officially right now
- # and the naming is just for convenience.
- if use examples ; then
- while IFS= read -r -d '' file ; do
- python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
- done < <(find "${S}"/examples -type f -executable -print0 || die)
- fi
-
- distutils-r1_python_install
-}