summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 09:46:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 09:46:28 +0100
commit79e250c027259fad2b313740a702346c888db870 (patch)
tree4ef8852427e12e52ffbbcee3aebce72dc2f9acec /dev-python/poetry-core
parentdev-ruby/rails: add 7.1.5 (diff)
downloadgentoo-79e250c027259fad2b313740a702346c888db870.tar.gz
gentoo-79e250c027259fad2b313740a702346c888db870.tar.bz2
gentoo-79e250c027259fad2b313740a702346c888db870.zip
dev-python/poetry-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest1
-rw-r--r--dev-python/poetry-core/poetry-core-1.9.0.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index aee8d2947808..eb18c828eaee 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,2 +1 @@
-DIST poetry-core-1.9.0.gh.tar.gz 371033 BLAKE2B 67e4674bcc45f6ce1737a26d8f1fd1ce6e6469d692cabe461fb2959b03ab3ca26b9e3848d9cbf533c5fd9bf7d75ac8b70a6aad0cce1930472971cc1ad530aedf SHA512 a2d63480f0df36fabe61c234377a4fa9ea0a1ddce449006162d6e49e849c92ad9c77d0a93aba7c51561bac16a77d5db00a95594bd5e2de328e1664f3f41f689b
DIST poetry-core-1.9.1.gh.tar.gz 371296 BLAKE2B 0ccd041a9c5491bb9c9234ca5094162995a3959be0272d916866770d6dbc67bb183c3b1b863b24fc1906c7d4fca0f9593d3c2c7571d4c3bb37c2f8f9dd6316c5 SHA512 9ca0aa68e4e7637e78b0a02cb3946b6efd29b91e99663f26fbb09736ff2fbfa13cd683337001b2200e3037e5d4adcd745bc6ff4c91a708880238f0b78719c281
diff --git a/dev-python/poetry-core/poetry-core-1.9.0.ebuild b/dev-python/poetry-core/poetry-core-1.9.0.ebuild
deleted file mode 100644
index d4f3b995dbca..000000000000
--- a/dev-python/poetry-core/poetry-core-1.9.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_TESTED=( pypy3 python3_{10..13} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1
-
-DESCRIPTION="Poetry PEP 517 Build Backend"
-HOMEPAGE="
- https://github.com/python-poetry/poetry-core/
- https://pypi.org/project/poetry-core/
-"
-SRC_URI="
- https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-# check inside vendors/pyproject.toml
-# (note that some are indirect deps)
-RDEPEND="
- >=dev-python/fastjsonschema-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/lark-1.1.3[${PYTHON_USEDEP}]
- >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- $(python_gen_cond_dep '
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.21[${PYTHON_USEDEP}]
- dev-vcs/git
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # remove vendoring of dependencies
- rm -r src/poetry/core/_vendor || die
- sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # These "fail" bacause of glob file path resulting from newer versions
- # in our tree than vendored. But those don't affect anything.
- tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
- tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
- )
-
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON} (unported deps)"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_mock
-}