summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-27 16:09:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-27 16:18:54 +0200
commitdc00b5bcb48a55e82d67e979e1ef908b0512955c (patch)
treee3115e12a19ff5247ee70a2cda6e4eaff363b18c /dev-python/priority
parentsys-devel/llvm-roc: Version bump to 4.2.0 and QA (diff)
downloadgentoo-dc00b5bcb48a55e82d67e979e1ef908b0512955c.tar.gz
gentoo-dc00b5bcb48a55e82d67e979e1ef908b0512955c.tar.bz2
gentoo-dc00b5bcb48a55e82d67e979e1ef908b0512955c.zip
dev-python/priority: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/priority')
-rw-r--r--dev-python/priority/Manifest1
-rw-r--r--dev-python/priority/priority-2.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/priority/Manifest b/dev-python/priority/Manifest
index 4af938515571..87b0b1dd9775 100644
--- a/dev-python/priority/Manifest
+++ b/dev-python/priority/Manifest
@@ -1 +1,2 @@
DIST priority-1.3.0.tar.gz 13827 BLAKE2B 8c100eb44ed42f4f624bfb37dd6f698a3da84812783bd44ba82afef565562379a7677b3cbc9e16c4ea5a5dcc91d0897fa47c341a81bc1875461a72aff328fcff SHA512 cefb13b15e99ef98c37fdd1486466c9e1d7d04b4574cbca1665fde7b7b44cc7d66964bed41184315a9b51bd6f9d0e02bbe113bfa004a754ac270170309b71e0a
+DIST priority-2.0.0.tar.gz 24792 BLAKE2B c230f74aba3153edafba4bf85965a726ac3d3f5e2293d7c496b65fda260722cc44e4582666eee9d715e0d0686695434f8e0cbbd089c105bb45b777bf6eb4d72c SHA512 f90648a3ff1ee4131f30e99ecd8c36110abf484733f507edefcede8fdcb9ec3a618b9278e85724855709f41facee438061e4c5cae201b6e916c22f4a451db575
diff --git a/dev-python/priority/priority-2.0.0.ebuild b/dev-python/priority/priority-2.0.0.ebuild
new file mode 100644
index 000000000000..ddf8d8fde3dd
--- /dev/null
+++ b/dev-python/priority/priority-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE="https://python-hyper.org/priority/en/latest/
+ https://github.com/python-hyper/priority
+ https://pypi.org/project/priority/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest