summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 08:19:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-17 08:40:54 +0100
commitcde6156b231206ebc9510cd2812e95c428ac7b41 (patch)
treea83f2f0653b986e60bafbb45fa8d6487272a0076 /dev-python/pudb/pudb-2024.1.ebuild
parentdev-python/uvicorn: Bump to 0.26.0 (diff)
downloadgentoo-cde6156b231206ebc9510cd2812e95c428ac7b41.tar.gz
gentoo-cde6156b231206ebc9510cd2812e95c428ac7b41.tar.bz2
gentoo-cde6156b231206ebc9510cd2812e95c428ac7b41.zip
dev-python/pudb: Bump to 2024.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pudb/pudb-2024.1.ebuild')
-rw-r--r--dev-python/pudb/pudb-2024.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pudb/pudb-2024.1.ebuild b/dev-python/pudb/pudb-2024.1.ebuild
new file mode 100644
index 000000000000..43e7248982cd
--- /dev/null
+++ b/dev-python/pudb/pudb-2024.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="https://pypi.org/project/pudb/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/urwid-2.4[${PYTHON_USEDEP}]
+ dev-python/urwid_readline[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest