summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-20 14:58:32 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-20 18:08:17 +0100
commitf550b3132ce950395f7c4651647687196194ee6c (patch)
treeec88dff91ae4db9ae817249ed10f70bef517c793 /dev-python/pure-eval
parentdev-python/wcwidth: Enable pypy3.11 (diff)
downloadgentoo-f550b3132ce950395f7c4651647687196194ee6c.tar.gz
gentoo-f550b3132ce950395f7c4651647687196194ee6c.tar.bz2
gentoo-f550b3132ce950395f7c4651647687196194ee6c.zip
dev-python/pure-eval: Enable pypy3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pure-eval')
-rw-r--r--dev-python/pure-eval/pure-eval-0.2.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pure-eval/pure-eval-0.2.3.ebuild b/dev-python/pure-eval/pure-eval-0.2.3.ebuild
index 111083d15962..551646bd03ee 100644
--- a/dev-python/pure-eval/pure-eval-0.2.3.ebuild
+++ b/dev-python/pure-eval/pure-eval-0.2.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
inherit distutils-r1 pypi
@@ -24,7 +24,7 @@ python_test() {
local EPYTEST_DESELECT=()
case ${EPYTHON} in
- pypy3)
+ pypy3*)
EPYTEST_DESELECT+=(
# https://github.com/alexmojaki/pure_eval/issues/15
tests/test_getattr_static.py::TestGetattrStatic::test_custom_object_dict