summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-14 04:18:49 +0000
committerSam James <sam@gentoo.org>2024-03-14 04:49:31 +0000
commitd8219a0dc4e5294b74fdcb6d447f4e1601580916 (patch)
tree500b6f04b7d2c9ad34b1e3ec7cb08f49a102793c /dev-python/pyasynchat/pyasynchat-1.0.4.ebuild
parentdev-python/pyasyncore: new package, add 1.0.4 (diff)
downloadgentoo-d8219a0dc4e5294b74fdcb6d447f4e1601580916.tar.gz
gentoo-d8219a0dc4e5294b74fdcb6d447f4e1601580916.tar.bz2
gentoo-d8219a0dc4e5294b74fdcb6d447f4e1601580916.zip
dev-python/pyasynchat: new package, add 1.0.4
Bug: https://bugs.gentoo.org/909998 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyasynchat/pyasynchat-1.0.4.ebuild')
-rw-r--r--dev-python/pyasynchat/pyasynchat-1.0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild b/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild
new file mode 100644
index 000000000000..b718b5d203ef
--- /dev/null
+++ b/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_12 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Make asynchat available for Python 3.12 onwards"
+HOMEPAGE="
+ https://github.com/simonrob/pyasynchat
+ https://pypi.org/project/pyasynchat/
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/pyasyncore-1.0.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ # Can't use d_e_t unittest (bug #926964)
+ eunittest tests
+}