summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 21:40:13 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 21:43:50 +0200
commit4aba16e91c025620a0a1c990064cd994a80a7e40 (patch)
tree9133f143823585640ff53ff237e293ca24bc8f51 /dev-python/pyclipper/pyclipper-1.1.0.ebuild
parentdev-python/defcon: New package needed for noto-emoji (diff)
downloadgentoo-4aba16e91c025620a0a1c990064cd994a80a7e40.tar.gz
gentoo-4aba16e91c025620a0a1c990064cd994a80a7e40.tar.bz2
gentoo-4aba16e91c025620a0a1c990064cd994a80a7e40.zip
dev-python/pyclipper: New package needed for noto-emoji
Bug: https://bugs.gentoo.org/616974 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/pyclipper/pyclipper-1.1.0.ebuild')
-rw-r--r--dev-python/pyclipper/pyclipper-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyclipper/pyclipper-1.1.0.ebuild b/dev-python/pyclipper/pyclipper-1.1.0.ebuild
new file mode 100644
index 000000000000..98a6fe8fc6ce
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}