summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pycxx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest2
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-installation.patch25
-rw-r--r--dev-python/pycxx/metadata.xml15
-rw-r--r--dev-python/pycxx/pycxx-6.2.5.ebuild37
-rw-r--r--dev-python/pycxx/pycxx-6.2.6.ebuild37
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
new file mode 100644
index 000000000000..f90b016296b4
--- /dev/null
+++ b/dev-python/pycxx/Manifest
@@ -0,0 +1,2 @@
+DIST pycxx-6.2.5.tar.gz 141302 SHA256 f125c1b569d32dcfc5bdca565be0311306a2d759196460a5cac665cb515b014c SHA512 c7a5eeacdcb3f68e0a2336a33e6a84d6a7b240e4d232ce0f2676c4a467bf2c8b109eebd63ee42b655efa1f1993fe66a590459a9fbe7315b6c0a57501c73ff3b4 WHIRLPOOL 0792cf9050a21a3774d13124838300663f3b0fe458a243d9aadff2177772e5be0516e0c8a806c572401c28d59c98a252162267c65fc9010a6ea0af0bbdb6c254
+DIST pycxx-6.2.6.tar.gz 141547 SHA256 3e960db53dea640473410ea20063afe7fcfcb61c107334d7ff6af96d384c11fe SHA512 9a6c30acb99c112497c02fb0826dc0197bbf4b813d25eab3f7d6537dfd83db8150c94f617f79810bbcca64496b8d6e67b1a41446523d66031c54c21e0425ea0c WHIRLPOOL 570cc1ccd12748481c74aefe863a2cef2d2d048ddbeceeeea01477a6d1765f38582f3c9112c8d5fddf6f534b91c74aea11b38aab8da04ced18280047a0821090
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
new file mode 100644
index 000000000000..5f6bfa74f4be
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
@@ -0,0 +1,25 @@
+--- setup.py
++++ setup.py
+@@ -3,10 +3,18 @@
+ from distutils.command.install import install
+ from distutils.core import setup
+
+-headers = (glob( os.path.join( "CXX","*.hxx" ) )
+- +glob( os.path.join( "CXX","*.h" ) ))
+-sources = (glob( os.path.join( "Src", "*.cxx" ) )
+- +glob( os.path.join( "Src", "*.c" ) ))
++headers = (glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.hxx" ) )
++ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) ))
++headers += [header for header in
++ glob( os.path.join( "CXX", "*.hxx" ) ) +
++ glob( os.path.join( "CXX", "*.h" ) )
++ if os.path.sep.join((os.path.split(header)[0], "Python%s" % sys.version_info[0], os.path.split(header)[1])) not in headers]
++sources = (glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.cxx" ) )
++ +glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.c" ) ))
++sources += [source for source in
++ glob( os.path.join( "Src", "*.cxx" ) ) +
++ glob( os.path.join( "Src", "*.c" ) )
++ if os.path.sep.join((os.path.split(source)[0], "Python%s" % sys.version_info[0], os.path.split(source)[1])) not in sources]
+
+
+ class my_install (install):
diff --git a/dev-python/pycxx/metadata.xml b/dev-python/pycxx/metadata.xml
new file mode 100644
index 000000000000..6ed1f5edceb1
--- /dev/null
+++ b/dev-python/pycxx/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ PyCXX is a set of C++ facilities to make it easier to write Python
+ extensions. The chief way in which PyCXX makes it easier to write
+ Python extensions is that it increases the probability that
+ your program will not make a reference-counting error and will not
+ have to continually check error returns from the Python C API.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">cxx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycxx/pycxx-6.2.5.ebuild b/dev-python/pycxx/pycxx-6.2.5.ebuild
new file mode 100644
index 000000000000..2954372432cb
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # CXX/Python2/Config.hxx: No such file or directory
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+
+ # Remove python2 print statement
+ echo > Lib/__init__.py || die
+
+ local PATCHES=(
+ "${FILESDIR}/${PN}-6.2.3-installation.patch"
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/ )
+ use examples && local EXAMPLES=( Demo/Python{2,3}/ )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pycxx/pycxx-6.2.6.ebuild b/dev-python/pycxx/pycxx-6.2.6.ebuild
new file mode 100644
index 000000000000..a5c539c59988
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # CXX/Python2/Config.hxx: No such file or directory
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+
+ # Remove python2 print statement
+ echo > Lib/__init__.py || die
+
+ local PATCHES=(
+ "${FILESDIR}/${PN}-6.2.3-installation.patch"
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ use examples && local EXAMPLES=( Demo/Python{2,3}/. )
+ distutils-r1_python_install_all
+}