summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-14 14:07:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-14 14:18:55 +0200
commit451dc9f1cd791b163e7fe44899aac08d0de92296 (patch)
tree7ac7ec3911d2b2116cb7d2c07592c7d571eea26c /dev-python/pydantic
parentnet-dialup/speedtouch-usb: EAPI=8, refactor, cleanup (diff)
downloadgentoo-451dc9f1cd791b163e7fe44899aac08d0de92296.tar.gz
gentoo-451dc9f1cd791b163e7fe44899aac08d0de92296.tar.bz2
gentoo-451dc9f1cd791b163e7fe44899aac08d0de92296.zip
dev-python/pydantic: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-2.7.1.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 32e39d677a70..9d5ed11e1f7d 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,4 +1,3 @@
-DIST pydantic-2.7.1.tar.gz 713923 BLAKE2B deeb9a63b290c8c3227c386b2982e11fb9385d16cb30e3522138219aef526dd7a077ddf496c92f8e3ed34ccbe21654177c539727e75bc209915f27817dfc62df SHA512 6b85c37384629e3df5f2b58e39ee9bf67f902b1ad2b05eb1298f03da8a945fc8f0865408948ad5deef76ca1d014f360ba778d4d957b6e7e158d2aa5c22861bd9
DIST pydantic-2.7.2.tar.gz 714293 BLAKE2B 0c8e647930b9ef1abfa1818b7d71eb41e5032d835f6772c60caab1cd02473cf163e8e2259bfcb57894c868242ebd6a8f343cee6ae7a3a49aa45b14ae20675269 SHA512 0ef9932afb1a57cf79bbd4a877cf002384f18cf32a7132a9913642ac6d273284d0bc7f8d8fc66361e61a0584cf38ef4630d68755567878f6f907cde0d9e9bdc1
DIST pydantic-2.7.3.tar.gz 714386 BLAKE2B 6f9e9c9d4c7e6e643d5b72cb368e44e2875a99f94b00525fd581906df7d5522f4467e2e6139bb893d83d27388a09e7935089684c62098e8d7770160b341e4295 SHA512 6d43e741444036acd38094e73966bf98fa318512a5b54774a08fa6bfc94f500a2448d9e96ebc76741a3f30a6cd86b96aa8fd98acabe2846744a0b443502d99a4
DIST pydantic-2.7.4.tar.gz 714127 BLAKE2B c9d6df84799d1c8a69bf7d203609db3ba533380919d1f47ae84eb83186ef9ffbbab5bea9b9c4918c65d35d4b2103107df3c7e5e314195bd84807d216226490b6 SHA512 9a36041a24306761f2528aaca196d0b3e160cf46d71596fcd3df0169b9dd68ce810b88bcbe15dc9c0126551d0d7e33e4c3014b97daaf5d68ce68c0f8d6ffaf81
diff --git a/dev-python/pydantic/pydantic-2.7.1.ebuild b/dev-python/pydantic/pydantic-2.7.1.ebuild
deleted file mode 100644
index be197bf2b656..000000000000
--- a/dev-python/pydantic/pydantic-2.7.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Data parsing and validation using Python type hints"
-HOMEPAGE="
- https://github.com/pydantic/pydantic/
- https://pypi.org/project/pydantic/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
- ~dev-python/pydantic-core-2.18.2[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
- test? (
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/dirty-equals[${PYTHON_USEDEP}]
- >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/Faker-18.13.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/benchmark/d' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
- local EPYTEST_IGNORE=(
- # require pytest-examples
- tests/test_docs.py
- # benchmarks
- tests/benchmarks
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_mock
-}