summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyds9
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyds9')
-rw-r--r--dev-python/pyds9/Manifest1
-rw-r--r--dev-python/pyds9/metadata.xml12
-rw-r--r--dev-python/pyds9/pyds9-1.7.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pyds9/Manifest b/dev-python/pyds9/Manifest
new file mode 100644
index 000000000000..5e55965a090e
--- /dev/null
+++ b/dev-python/pyds9/Manifest
@@ -0,0 +1 @@
+DIST pyds9-1.7.tar.gz 879882 SHA256 026a86827fa93f074e2a90b9d831ba79253f312fa331f6a6a508cfa91fa81aac SHA512 8622cf40db65228553abc2f3dea346d9c948706a2681217a9383589d4df0143c42ef859dff12689f699b0fb40806945232c336539f37eb2c78754f9779043bcb WHIRLPOOL abc2d11817519e844f61319b0ba30276a9bb48b6a3beb5e6b7c097717cc86aeeb1960f58d62a21a9ce5d4bc37c05b8cee181abc1cc12e2821a5e878d64f1f175
diff --git a/dev-python/pyds9/metadata.xml b/dev-python/pyds9/metadata.xml
new file mode 100644
index 000000000000..b1d6caffdd81
--- /dev/null
+++ b/dev-python/pyds9/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ The XPA messaging system provides seamless communication between
+ many kinds of Unix programs, including Tcl/Tk programs such as
+ ds9. The pyds9 module uses a Python interface to XPA to communicate
+ with ds9. It supports communication with all of ds9’s XPA access
+ points.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyds9/pyds9-1.7.ebuild b/dev-python/pyds9/pyds9-1.7.ebuild
new file mode 100644
index 000000000000..38a742fd881f
--- /dev/null
+++ b/dev-python/pyds9/pyds9-1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 multilib
+
+XPAPV=2.1.15
+
+DESCRIPTION="Python interface to XPA to communicate with DS9"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9/pyds9/"
+SRC_URI="http://hea-www.harvard.edu/RD/download/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=x11-libs/xpa-${XPAPV}"
+RDEPEND="${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ || ( dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/pyfits[${PYTHON_USEDEP}] )"
+
+DOCS=(changelog README)
+
+src_prepare() {
+ rm -r xpa-${XPAPV} || die
+ sed -i \
+ -e "/py_modules/s|\],|\])|" \
+ -e '/data_files/,$ d' \
+ setup.py || die
+ sed -i \
+ -e "s|./xpa-${XPAPV}|${EROOT%/}/usr/$(get_libdir)|" \
+ xpa.py || die
+ sed -i \
+ -e "s|sys.path|['${EROOT%/}/usr/bin']|" \
+ ds9.py || die
+ distutils-r1_src_prepare
+}