summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-31 13:52:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-31 13:55:03 +0100
commit273032462be1becbfd11b6480cf46c49466c7334 (patch)
tree69301bea9bda6d3bf301374bd2132e9c1b91678f /dev-python/pyelemental
parentsci-libs/cifparse-obj: Add gcc5 support (diff)
downloadgentoo-273032462be1becbfd11b6480cf46c49466c7334.tar.gz
gentoo-273032462be1becbfd11b6480cf46c49466c7334.tar.bz2
gentoo-273032462be1becbfd11b6480cf46c49466c7334.zip
dev-python/pyelemental: Add missing -std declaration
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570218 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyelemental')
-rw-r--r--dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild b/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild
index a815361614a4..c448087a5da9 100644
--- a/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild
+++ b/dev-python/pyelemental/pyelemental-1.2.0-r1.ebuild
@@ -3,9 +3,10 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python bindings for libelemental (sci-chemistry/gelemental)"
HOMEPAGE="http://freecode.com/projects/gelemental/"
@@ -22,6 +23,11 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
+python_prepare_all() {
+ append-cxxflags -std=c++11
+ distutils-r1_python_prepare_all
+}
+
python_install_all() {
use doc && local HTML_DOCS=( docs/html/. )
distutils-r1_python_install_all